# CVE-2026-104126: JumpServer: Ansible Automation Template Rendering Allows Unsafe Lookup Plugin Invocation

> Authenticated users can inject malicious Ansible template expressions to disclose sensitive files or execute limited commands within the automation process.

- **Severity:** Medium 6.0 (`CVSS:3.1/AV:N/AC:L/PR:H/UI:N/S:U/C:H/I:L/A:L`)
- **Exploited in the wild:** Not known
- **Login needed:** An administrator
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** No
- **Published:** 13 Oct 2026
- **Updated:** 16 Oct 2026
- **Also known as:** GHSA-gr5x-5c4h-867g

## What is CVE-2026-104126?

CVE-2026-104126 is a medium-severity code injection vulnerability in jumpserver, published on 13 Oct 2026. An attacker needs administrator access to exploit it, with no action from the victim.

### Official description

JumpServer is an open source bastion host and an operation and maintenance security audit system. Prior to 4.10.17-lts, JumpServer's Ansible-based automation rendering can evaluate attacker-controlled template expressions from users who have permission to create or execute affected automation tasks. Crafted content can invoke sensitive Ansible lookup behavior, including file, pipe, env, and password lookups, within the Ansible execution context, which can disclose files or environment values and may permit limited command execution under the privileges of the automation process. The issue does not provide unauthenticated access or direct access to unrelated JumpServer assets. This issue is fixed in version 4.10.17-lts.

Weakness: CWE-94 (Improper Control of Generation of Code)

## Which versions are affected by CVE-2026-104126?


## How do I fix CVE-2026-104126?

No fix has been published for CVE-2026-104126 yet. Limit exposure of the affected software until one is available.

## Is CVE-2026-104126 being exploited?

There is no known exploitation of CVE-2026-104126 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-104126 and fix it if it is affected.

What it is: CVE-2026-104126 is a medium-severity code injection vulnerability in jumpserver, published on 13 Oct 2026. An attacker needs administrator access to exploit it, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-104126 in the wild and no public exploit code.

Affected product: jumpserver. No package-level version data is available, so check the vendor advisory linked from the reference page.

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-104126/ (Markdown: https://insights.sbomify.com/CVE-2026-104126/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-104126
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-104126
- OSV: https://osv.dev/vulnerability/CVE-2026-104126

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-104126/
Summaries are generated and may contain mistakes; the official description above is the record.
