{"answers":{"affected":"","exploited":"It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-104140 exists.","fix":"Upgrade to a fixed version.","what":"CVE-2026-104140 is a medium-severity cross-site scripting vulnerability in QGIS, published on 12 Oct 2026. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link."},"fix_prompt":"Check this codebase for CVE-2026-104140 and fix it if it is affected.\n\nWhat it is: CVE-2026-104140 is a medium-severity cross-site scripting vulnerability in QGIS, published on 12 Oct 2026. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.\nExploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-104140 exists.\n\nAffected product: QGIS. No package-level version data is available, so check the vendor advisory linked from the reference page.\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2026-104140/ (Markdown: https://insights.sbomify.com/CVE-2026-104140/index.md)","id":"CVE-2026-104140","markdown":"https://insights.sbomify.com/CVE-2026-104140/index.md","name":"CVE-2026-104140","record":{"aliases":["DEBIAN-CVE-2026-104140","GHSA-cr49-pm9v-m788","UBUNTU-CVE-2026-104140"],"analysis":{"component_type":"server_software","fix_type":"upgrade","impacts":["account_takeover","data_read"],"network_reachable":"yes","non_default_config":false,"product_category":"QGIS Server","requires_auth":"none","summary":"Attackers can inject malicious scripts into QGIS Server WFS3 HTML responses, allowing session hijacking or unauthorized actions when users view feature data.","user_interaction":"required","vuln_class":"xss"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"GitHub_M","cpe":[],"cvss":{"score":6.1,"severity":"medium","source":"cna","vector":"CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N","version":"3.1"},"cwes":[{"id":"CWE-79","name":"Improper Neutralization of Input During Web Page Generation"}],"description":"QGIS is a free, open source, cross-platform geographic information system. Prior to 3.44.12 and 4.0.0 through 4.2.3, QGIS Server renders feature data in WFS3 (OGC API Features) HTML responses without HTML escaping. Attacker-controlled feature.properties values from a published writable vector layer reach resources/server/api/ogc/templates/wfs3/getFeatures.html through QgsServerOgcApiHandler::htmlDump and the if_nullptr_null_str callback. A user who opens an items HTML page can execute stored markup or script in the QGIS Server origin, which can expose the viewer's session data or issue authenticated requests with the viewer's privileges. This issue is fixed in version 3.44.12.","ecosystems":[],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"weaponised"},"has_fix":true,"headline":"QGIS: Stored XSS in WFS3 getFeatures HTML page via unescaped feature attribute values","id":"CVE-2026-104140","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":null,"product":null,"products":[],"type":"xss","year":"2026"},"n_packages":0,"n_references":6,"next":{"headline":"DataEase: SQL Injection in datasource metadata identifiers","id":"CVE-2026-104141"},"packages":[],"prev":{"headline":"JumpServer: Ansible Automation Template Rendering Allows Unsafe Lookup Plugin Invocation","id":"CVE-2026-104126"},"products":["QGIS"],"published":"2026-10-12","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"poc","technical_impact":"partial"},"state":"PUBLISHED","updated":"2026-10-13","vendors":["qgis"]},"summary":"Attackers can inject malicious scripts into QGIS Server WFS3 HTML responses, allowing session hijacking or unauthorized actions when users view feature data.","url":"https://insights.sbomify.com/CVE-2026-104140/"}