# CVE-2026-104252: Vitess vttablet /twopcz reflected XSS

> An attacker can execute scripts in an operator's browser via the vttablet debug endpoint, potentially exposing sensitive diagnostic data.

- **Severity:** Critical 9.8 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 13 Oct 2026
- **Updated:** 15 Oct 2026
- **Also known as:** AZL-108039, GHSA-v75v-6fpf-gvw8

## What is CVE-2026-104252?

CVE-2026-104252 is a critical cross-site scripting vulnerability in vitessio vitess, published on 13 Oct 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Vitess is a database clustering system for horizontal scaling of MySQL. Prior to 23.0.5 and 24.0.2, twopczHandler in go/vt/vttablet/tabletserver/twopcz.go writes the Action and dtid form values from the vttablet and vtcombo /twopcz HTTP debug endpoint into a text/html response without HTML escaping. Under the default allow-all ACL policy, a remote unauthenticated attacker can send an operator a crafted request that executes script in the operator's browser after the request is opened. The script runs with the vttablet debug origin and can read same-origin diagnostic endpoints that expose query, transaction, environment, variable, or profiling data available in that deployment. This issue is fixed in versions 23.0.5 and 24.0.2.

Weakness: CWE-79 (Improper Neutralization of Input During Web Page Generation)

## Which versions are affected by CVE-2026-104252?

4 open source packages ship an affected version, including vitess.io/vitess. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `vitess.io/vitess` | Go | All versions | 0.23.5 |
| `vitess.io/vitess` | Go | All versions | 0.23.5 |
| `vitess.io/vitess` | Go | From 0.24.0 | 0.24.2 |
| `vitess.io/vitess` | Go | From 0.24.0 | 0.24.2 |

Products: Linuxfoundation Vitess.

## How do I fix CVE-2026-104252?

Upgrade vitess.io/vitess to a fixed version for your release line: 0.23.5 or 0.24.2.

## Is CVE-2026-104252 being exploited?

There is no known exploitation of CVE-2026-104252 in the wild and no public exploit code.

## Other vulnerabilities in vitessio vitess

- [CVE-2026-27969](https://insights.sbomify.com/CVE-2026-27969/): Vitess users with backup storage access can write to arbitrary file paths on restore (critical 9.3)
- [CVE-2026-27965](https://insights.sbomify.com/CVE-2026-27965/): Vitess users with backup storage access can gain unauthorized access to production deployment environments (high 8.4)
- [CVE-2023-29195](https://insights.sbomify.com/CVE-2023-29195/): Vitess VTAdmin users that can create shards can deny access to other functions (medium 4.1)
- [CVE-2023-29194](https://insights.sbomify.com/CVE-2023-29194/): vitess allows users to create keyspaces that can deny access to already existing keyspaces (medium 4.1)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-104252 and fix it if it is affected.

What it is: CVE-2026-104252 is a critical cross-site scripting vulnerability in vitessio vitess, published on 13 Oct 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-104252 in the wild and no public exploit code.

Affected packages and fixed versions:
- vitess.io/vitess (Go): affected all versions; fixed in 0.23.5
- vitess.io/vitess (Go): affected all versions; fixed in 0.23.5
- vitess.io/vitess (Go): affected from 0.24.0; fixed in 0.24.2
- vitess.io/vitess (Go): affected from 0.24.0; fixed in 0.24.2

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-104252/ (Markdown: https://insights.sbomify.com/CVE-2026-104252/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-104252
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-104252
- OSV: https://osv.dev/vulnerability/CVE-2026-104252

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-104252/
Summaries are generated and may contain mistakes; the official description above is the record.
