# CVE-2026-104434: Zebra before 8.0.0 Denial of Service via z_listunifiedreceivers RPC

> Authenticated RPC clients can crash the Zcash node by submitting invalid Unified Addresses, causing a denial of service.

- **Severity:** High 7.1 (`CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:N/VC:N/VI:N/VA:H/SC:N/SI:N/SA:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** No
- **Published:** 2 Oct 2026
- **Updated:** 2 Oct 2026
- **Also known as:** GHSA-c8w6-x74f-vmg3, GHSA-fxgv-g76m-8hg2

## What is CVE-2026-104434?

CVE-2026-104434 is a high-severity denial of service vulnerability in ZcashFoundation zebra, published on 2 Oct 2026. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

ZcashFoundation Zebra zebra-rpc before 8.0.0 and zebrad before 4.5.0 contain a reachable assertion in the z_listunifiedreceivers RPC handler, which calls expect() on Sapling receiver parsing that fails for Unified Addresses carrying invalid Jubjub points. Authenticated RPC clients can submit such an address to abort the zebrad process, repeatably keeping the node offline.

Weakness: CWE-617 (Reachable Assertion)

## Which versions are affected by CVE-2026-104434?

4 open source packages ship an affected version, including zebra-rpc and zebrad.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `zebra-rpc` | crates.io | All versions | 8.0.0 |
| `zebra-rpc` | crates.io | All versions | 8.0.0 |
| `zebrad` | crates.io | All versions | 4.5.0 |
| `zebrad` | crates.io | All versions | 4.5.0 |

## How do I fix CVE-2026-104434?

Upgrade zebra-rpc to 8.0.0 or later.

## Is CVE-2026-104434 being exploited?

There is no known exploitation of CVE-2026-104434 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-104434 and fix it if it is affected.

What it is: CVE-2026-104434 is a high-severity denial of service vulnerability in ZcashFoundation zebra, published on 2 Oct 2026. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-104434 in the wild and no public exploit code.

Affected packages and fixed versions:
- zebra-rpc (crates.io): affected all versions; fixed in 8.0.0
- zebra-rpc (crates.io): affected all versions; fixed in 8.0.0
- zebrad (crates.io): affected all versions; fixed in 4.5.0
- zebrad (crates.io): affected all versions; fixed in 4.5.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-104434/ (Markdown: https://insights.sbomify.com/CVE-2026-104434/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-104434
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-104434
- OSV: https://osv.dev/vulnerability/CVE-2026-104434

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-104434/
Summaries are generated and may contain mistakes; the official description above is the record.
