# CVE-2026-104436: Zebra before 4.5.0 CPU Amplification via Uncapped getblocks/getheaders Locator Length

> Remote attackers can exhaust system resources by sending oversized block locator vectors, causing denial of service in Zcash nodes.

- **Severity:** Medium 6.3 (`CVSS:4.0/AV:N/AC:H/AT:P/PR:N/UI:N/VC:N/VI:N/VA:L/SC:N/SI:N/SA:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** No
- **Published:** 2 Oct 2026
- **Updated:** 29 Oct 2026
- **Also known as:** GHSA-443g-gwgp-49x4, GHSA-4m38-rccq-j8gv

## What is CVE-2026-104436?

CVE-2026-104436 is a medium-severity denial of service vulnerability in ZcashFoundation zebra, published on 2 Oct 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Zebra before 4.5.0 contains an uncontrolled resource consumption vulnerability that allows remote P2P peers to exhaust blocking-pool threads by sending oversized block locator vectors. Attackers can send getblocks or getheaders messages with up to 65,535 locator hashes, triggering per-hash chain lookups that degrade block validation, RPC, and mempool performance.

Weakness: CWE-770 (Allocation of Resources Without Limits or Throttling)

## Which versions are affected by CVE-2026-104436?

4 open source packages ship an affected version, including zebra-chain and zebrad.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `zebra-chain` | crates.io | All versions | 8.0.0 |
| `zebra-chain` | crates.io | All versions | 8.0.0 |
| `zebrad` | crates.io | All versions | 4.5.0 |
| `zebrad` | crates.io | All versions | 4.5.0 |

## How do I fix CVE-2026-104436?

Upgrade zebra-chain to 8.0.0 or later.

## Is CVE-2026-104436 being exploited?

There is no known exploitation of CVE-2026-104436 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-104436 and fix it if it is affected.

What it is: CVE-2026-104436 is a medium-severity denial of service vulnerability in ZcashFoundation zebra, published on 2 Oct 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-104436 in the wild and no public exploit code.

Affected packages and fixed versions:
- zebra-chain (crates.io): affected all versions; fixed in 8.0.0
- zebra-chain (crates.io): affected all versions; fixed in 8.0.0
- zebrad (crates.io): affected all versions; fixed in 4.5.0
- zebrad (crates.io): affected all versions; fixed in 4.5.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-104436/ (Markdown: https://insights.sbomify.com/CVE-2026-104436/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-104436
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-104436
- OSV: https://osv.dev/vulnerability/CVE-2026-104436

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-104436/
Summaries are generated and may contain mistakes; the official description above is the record.
