# CVE-2026-104437: Zebra before 4.4.0 Consensus Split via SIGHASH_SINGLE Missing-Output Handling

> Attackers can cause consensus divergence by crafting invalid transactions, leading to network partitioning or denial of service in Zebra nodes.

- **Severity:** High 8.3 (`CVSS:4.0/AV:N/AC:L/AT:P/PR:N/UI:N/VC:N/VI:H/VA:H/SC:N/SI:N/SA:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** No
- **Published:** 2 Oct 2026
- **Updated:** 6 Oct 2026
- **Also known as:** GHSA-cwfq-rfcr-8hmp, GHSA-wc6w-gfmg-rf5p

## What is CVE-2026-104437?

CVE-2026-104437 is a high-severity vulnerability in ZcashFoundation zebra, published on 2 Oct 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Zebra before 4.4.0 contains a consensus divergence vulnerability in V5 transparent signature verification, computing a ZIP-244 digest for SIGHASH_SINGLE inputs lacking corresponding outputs instead of failing. Attackers can craft V5 transactions with fewer outputs than inputs that Zebra accepts and templates via getblocktemplate, producing blocks zcashd rejects.

Weakness: CWE-347 (Improper Verification of Cryptographic Signature)

## Which versions are affected by CVE-2026-104437?

2 open source packages ship an affected version, including zebrad.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `zebrad` | crates.io | All versions | 4.4.0 |
| `zebrad` | crates.io | All versions | 4.4.0 |

## How do I fix CVE-2026-104437?

Upgrade zebrad to 4.4.0 or later.

## Is CVE-2026-104437 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-104437 exists.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-104437 and fix it if it is affected.

What it is: CVE-2026-104437 is a high-severity vulnerability in ZcashFoundation zebra, published on 2 Oct 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-104437 exists.

Affected packages and fixed versions:
- zebrad (crates.io): affected all versions; fixed in 4.4.0
- zebrad (crates.io): affected all versions; fixed in 4.4.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-104437/ (Markdown: https://insights.sbomify.com/CVE-2026-104437/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-104437
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-104437
- OSV: https://osv.dev/vulnerability/CVE-2026-104437

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-104437/
Summaries are generated and may contain mistakes; the official description above is the record.
