{"answers":{"affected":"2 open source packages ship an affected version, including yeswiki/yeswiki.","exploited":"It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-104473 exists.","fix":"Upgrade yeswiki/yeswiki to 4.6.0 or later.","what":"CVE-2026-104473 is a medium-severity cross-site scripting vulnerability in yeswiki, published on 2 Oct 2026. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link."},"fix_prompt":"Check this codebase for CVE-2026-104473 and fix it if it is affected.\n\nWhat it is: CVE-2026-104473 is a medium-severity cross-site scripting vulnerability in yeswiki, published on 2 Oct 2026. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.\nExploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-104473 exists.\n\nAffected packages and fixed versions:\n- yeswiki/yeswiki (Packagist): affected all versions; fixed in 4.6.0\n- yeswiki/yeswiki (Packagist): affected all versions; fixed in 4.6.0\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2026-104473/ (Markdown: https://insights.sbomify.com/CVE-2026-104473/index.md)","id":"CVE-2026-104473","markdown":"https://insights.sbomify.com/CVE-2026-104473/index.md","name":"CVE-2026-104473","record":{"aliases":["GHSA-5724-x3rh-5qqq","GHSA-8mcv-55p8-4xgh"],"analysis":{"component_type":"web_application","fix_type":"upgrade","impacts":["account_takeover","security_bypass"],"network_reachable":"yes","non_default_config":false,"product_category":"YesWiki","requires_auth":"none","summary":"Remote attackers can inject JavaScript via unsanitized parameters in YesWiki, allowing session hijacking and unauthorized actions against backend functionality.","user_interaction":"required","vuln_class":"xss"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"VulnCheck","cpe":[],"cvss":{"score":5.1,"severity":"medium","source":"cna","vector":"CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:A/VC:N/VI:N/VA:N/SC:L/SI:L/SA:N","version":"4.0"},"cwes":[{"id":"CWE-79","name":"Improper Neutralization of Input During Web Page Generation"}],"description":"YesWiki before 4.5.3 contains multiple reflected cross-site scripting vulnerabilities that allow remote attackers to inject JavaScript through unsanitized parameters such as incomingurl, id, file, tags, and template. Attackers can lure authenticated or unauthenticated users into opening crafted links to hijack sessions and trigger authenticated requests against backend functionality.","ecosystems":["Packagist"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"weaponised"},"has_fix":false,"headline":"YesWiki before 4.5.3 Multiple Reflected XSS via BazaR and listpages","id":"CVE-2026-104473","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Packagist","product":null,"products":[],"type":"xss","year":"2026"},"n_packages":2,"n_references":2,"next":{"headline":"OpenLiteSpeed before 1.9.3 Local Privilege Escalation via lsup.sh Auto-Update","id":"CVE-2026-104474"},"packages":[{"ecosystem":"Packagist","fixed":["4.6.0"],"introduced":["0"],"last_affected":[],"package":"yeswiki/yeswiki","purl":null,"source":"GHSA-5724-x3rh-5qqq"},{"ecosystem":"Packagist","fixed":["4.6.0"],"introduced":["0"],"last_affected":[],"package":"yeswiki/yeswiki","purl":"pkg:composer/yeswiki/yeswiki","source":"GHSA-5724-x3rh-5qqq"}],"prev":{"headline":"YesWiki before 4.6.7 Missing Authorization via Attachment Download Handler","id":"CVE-2026-104472"},"products":["yeswiki"],"published":"2026-10-02","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"poc","technical_impact":"partial"},"state":"PUBLISHED","updated":"2026-10-08","vendors":["YesWiki"]},"summary":"Remote attackers can inject JavaScript via unsanitized parameters in YesWiki, allowing session hijacking and unauthorized actions against backend functionality.","url":"https://insights.sbomify.com/CVE-2026-104473/"}