# CVE-2026-104473: YesWiki before 4.5.3 Multiple Reflected XSS via BazaR and listpages

> Remote attackers can inject JavaScript via unsanitized parameters in YesWiki, allowing session hijacking and unauthorized actions against backend functionality.

- **Severity:** Medium 5.1 (`CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:A/VC:N/VI:N/VA:N/SC:L/SI:L/SA:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** No
- **Published:** 2 Oct 2026
- **Updated:** 8 Oct 2026
- **Also known as:** GHSA-5724-x3rh-5qqq, GHSA-8mcv-55p8-4xgh

## What is CVE-2026-104473?

CVE-2026-104473 is a medium-severity cross-site scripting vulnerability in yeswiki, published on 2 Oct 2026. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

### Official description

YesWiki before 4.5.3 contains multiple reflected cross-site scripting vulnerabilities that allow remote attackers to inject JavaScript through unsanitized parameters such as incomingurl, id, file, tags, and template. Attackers can lure authenticated or unauthenticated users into opening crafted links to hijack sessions and trigger authenticated requests against backend functionality.

Weakness: CWE-79 (Improper Neutralization of Input During Web Page Generation)

## Which versions are affected by CVE-2026-104473?

2 open source packages ship an affected version, including yeswiki/yeswiki.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `yeswiki/yeswiki` | Packagist | All versions | 4.6.0 |
| `yeswiki/yeswiki` | Packagist | All versions | 4.6.0 |

## How do I fix CVE-2026-104473?

Upgrade yeswiki/yeswiki to 4.6.0 or later.

## Is CVE-2026-104473 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-104473 exists.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-104473 and fix it if it is affected.

What it is: CVE-2026-104473 is a medium-severity cross-site scripting vulnerability in yeswiki, published on 2 Oct 2026. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-104473 exists.

Affected packages and fixed versions:
- yeswiki/yeswiki (Packagist): affected all versions; fixed in 4.6.0
- yeswiki/yeswiki (Packagist): affected all versions; fixed in 4.6.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-104473/ (Markdown: https://insights.sbomify.com/CVE-2026-104473/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-104473
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-104473
- OSV: https://osv.dev/vulnerability/CVE-2026-104473

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-104473/
Summaries are generated and may contain mistakes; the official description above is the record.
