CVE-2026-104711 Apache Struts: OGNL injection in the legacy RESTful action mapper
Attackers can achieve remote code execution via OGNL injection in Apache Struts if the legacy RESTful action mapper is enabled.
- Exploited in the wild
- Not known
- Login needed
- Not needed
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- None listed
What is CVE-2026-104711?
CVE-2026-104711 is a critical code injection vulnerability in Apache Struts, published on 5 Oct 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Official description
Improper neutralization of special elements used in an expression language statement ('Expression Language Injection') vulnerability in Apache Struts. If the application is configured to use the legacy RESTful action mapper, a crafted request can inject an OGNL expression that may lead to remote code execution. Struts 7 is affected only when the OGNL allowlist is disabled; it is enabled by default. Applications using the default action mapper, the restful2 mapper, or the Struts REST plugin are not affected.
This issue affects Apache Struts: from 2.0.0 through 2.3.37, from 2.5.0 through 2.5.33, from 6.0.0 through 6.11.0, from 7.0.0 through 7.3.0.
Users are recommended to upgrade to version 6.12.0 or 7.4.0, which fixes the issue.
Weakness: CWE-917
Which versions are affected by CVE-2026-104711?
It affects 1 product.
Products include Apache Struts.
How do I fix CVE-2026-104711?
No fix has been published for CVE-2026-104711 yet. Limit exposure of the affected software until one is available.
Upgrade, and never evaluate templates, expressions or code built from user input. More about Code injection.
Is CVE-2026-104711 being exploited?
There is no known exploitation of CVE-2026-104711 in the wild and no public exploit code.
Other vulnerabilities in Apache Struts
Sources
Also known as GHSA-wfm5-pq4p-gff9.