CVE-2026-104713 Apache Struts: Unbounded request body read in the REST plugin
Attackers can exhaust server memory via unbounded REST plugin requests, causing denial of service for Apache Struts users.
- Exploited in the wild
- Not known
- Login needed
- Any signed-in user
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- None listed
What is CVE-2026-104713?
CVE-2026-104713 is a medium-severity denial of service vulnerability in Apache Struts, published on 5 Oct 2026. Any signed-in user can exploit it over the network, with no action from the victim.
Official description
Allocation of resources without limits or throttling vulnerability in the Apache Struts REST plugin. A request body is read into memory without any bound on how much will be accepted, so a single request can cause the server to allocate memory in proportion to its size, exhausting the Java heap and denying service to other users. No additional setting has to be enabled. Applications that do not use the REST plugin are not affected.
This issue affects Apache Struts: from 2.1.8 through 2.3.37, from 2.5.0 through 2.5.33, from 6.0.0 through 6.11.0, from 7.0.0 through 7.3.0.
Users are recommended to upgrade to version 6.12.0 or 7.4.0, which fixes the issue.
Weakness: CWE-770
Which versions are affected by CVE-2026-104713?
It affects 1 product.
Products include Apache Struts.
How do I fix CVE-2026-104713?
No fix has been published for CVE-2026-104713 yet. Limit exposure of the affected software until one is available.
Upgrade, then put limits on request size, rate and nesting depth so one client cannot exhaust the service. More about Denial of service.
Is CVE-2026-104713 being exploited?
There is no known exploitation of CVE-2026-104713 in the wild and no public exploit code.
Other vulnerabilities in Apache Struts
Sources
Also known as GHSA-3fxc-fh79-w9fr.