# CVE-2026-104713: Apache Struts: Unbounded request body read in the REST plugin

> Attackers can exhaust server memory via unbounded REST plugin requests, causing denial of service for Apache Struts users.

- **Severity:** Medium 6.5 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:N/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** No
- **Published:** 5 Oct 2026
- **Updated:** 6 Oct 2026
- **Also known as:** GHSA-3fxc-fh79-w9fr

## What is CVE-2026-104713?

CVE-2026-104713 is a medium-severity denial of service vulnerability in Apache Struts, published on 5 Oct 2026. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

Allocation of resources without limits or throttling vulnerability in the Apache Struts REST plugin. A request body is read into memory without any bound on how much will be accepted, so a single request can cause the server to allocate memory in proportion to its size, exhausting the Java heap and denying service to other users. No additional setting has to be enabled. Applications that do not use the REST plugin are not affected.

This issue affects Apache Struts: from 2.1.8 through 2.3.37, from 2.5.0 through 2.5.33, from 6.0.0 through 6.11.0, from 7.0.0 through 7.3.0.

Users are recommended to upgrade to version 6.12.0 or 7.4.0, which fixes the issue.

Weakness: CWE-770 (Allocation of Resources Without Limits or Throttling)

## Which versions are affected by CVE-2026-104713?

It affects 1 product.


Products: Apache Struts.

## How do I fix CVE-2026-104713?

No fix has been published for CVE-2026-104713 yet. Limit exposure of the affected software until one is available.

## Is CVE-2026-104713 being exploited?

There is no known exploitation of CVE-2026-104713 in the wild and no public exploit code.

## Other vulnerabilities in Apache Struts

- [CVE-2020-17530](https://insights.sbomify.com/CVE-2020-17530/): Apache Struts Remote Code Execution (critical 9.8, exploited in the wild)
- [CVE-2017-9791](https://insights.sbomify.com/CVE-2017-9791/): Apache Struts 1 Improper Input Validation (critical 9.8, exploited in the wild)
- [CVE-2017-5638](https://insights.sbomify.com/CVE-2017-5638/): Apache Struts Remote Code Execution (critical 9.8, exploited in the wild)
- [CVE-2012-0391](https://insights.sbomify.com/CVE-2012-0391/): Apache Struts 2 Improper Input Validation (critical 9.8, exploited in the wild)
- [CVE-2018-11776](https://insights.sbomify.com/CVE-2018-11776/): Apache Struts Remote Code Execution (high 8.1, exploited in the wild)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-104713 and fix it if it is affected.

What it is: CVE-2026-104713 is a medium-severity denial of service vulnerability in Apache Struts, published on 5 Oct 2026. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-104713 in the wild and no public exploit code.

Affected product: Apache Struts. No package-level version data is available, so check the vendor advisory linked from the reference page.

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-104713/ (Markdown: https://insights.sbomify.com/CVE-2026-104713/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-104713
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-104713
- OSV: https://osv.dev/vulnerability/CVE-2026-104713

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-104713/
Summaries are generated and may contain mistakes; the official description above is the record.
