# CVE-2026-104714: Apache Struts: Shared message formatter exposes date and time values across concurrent requests

> Concurrent requests sharing a message formatter can leak user data or cause server errors in Apache Struts applications using localized date/time formatting.

- **Severity:** High 8.8 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** No
- **Published:** 5 Oct 2026
- **Updated:** 6 Oct 2026
- **Also known as:** GHSA-5fhf-r6vm-6wj7

## What is CVE-2026-104714?

CVE-2026-104714 is a high-severity vulnerability in Apache Struts, published on 5 Oct 2026. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

Concurrent execution using shared resource with improper synchronization ('race condition') vulnerability in Apache Struts. Where a localized message formats a date or time argument, the formatter retained for that message by the application-wide text provider is used by concurrently served requests without isolation, so a value belonging to one user can appear in another user's response, or the rendering can fail and surface as a server error. Applications whose localized messages format no date or time arguments are not affected.

This issue affects Apache Struts: from 2.0.0 through 2.3.37, from 2.5.0 through 2.5.33, from 6.0.0 through 6.11.0, from 7.0.0 through 7.3.0.

Users are recommended to upgrade to version 6.12.0 or 7.4.0, which fixes the issue.

Weakness: CWE-362 (Concurrent Execution using Shared Resource with Improper Synchronization)

## Which versions are affected by CVE-2026-104714?

It affects 1 product.


Products: Apache Struts.

## How do I fix CVE-2026-104714?

No fix has been published for CVE-2026-104714 yet. Limit exposure of the affected software until one is available.

## Is CVE-2026-104714 being exploited?

There is no known exploitation of CVE-2026-104714 in the wild and no public exploit code.

## Other vulnerabilities in Apache Struts

- [CVE-2020-17530](https://insights.sbomify.com/CVE-2020-17530/): Apache Struts Remote Code Execution (critical 9.8, exploited in the wild)
- [CVE-2017-9791](https://insights.sbomify.com/CVE-2017-9791/): Apache Struts 1 Improper Input Validation (critical 9.8, exploited in the wild)
- [CVE-2017-5638](https://insights.sbomify.com/CVE-2017-5638/): Apache Struts Remote Code Execution (critical 9.8, exploited in the wild)
- [CVE-2012-0391](https://insights.sbomify.com/CVE-2012-0391/): Apache Struts 2 Improper Input Validation (critical 9.8, exploited in the wild)
- [CVE-2018-11776](https://insights.sbomify.com/CVE-2018-11776/): Apache Struts Remote Code Execution (high 8.1, exploited in the wild)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-104714 and fix it if it is affected.

What it is: CVE-2026-104714 is a high-severity vulnerability in Apache Struts, published on 5 Oct 2026. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-104714 in the wild and no public exploit code.

Affected product: Apache Struts. No package-level version data is available, so check the vendor advisory linked from the reference page.

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-104714/ (Markdown: https://insights.sbomify.com/CVE-2026-104714/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-104714
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-104714
- OSV: https://osv.dev/vulnerability/CVE-2026-104714

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-104714/
Summaries are generated and may contain mistakes; the official description above is the record.
