# CVE-2026-104827: react/http: Unbounded HTTP Client Response Header Buffering Leads to Memory Exhaustion DoS

> A remote server can cause memory exhaustion and crash the application by streaming unbounded HTTP response headers to the ReactPHP HTTP client.

- **Severity:** High 7.5 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 15 Oct 2026
- **Updated:** 16 Oct 2026
- **Also known as:** GHSA-g4f2-2pf3-2pwj, UBUNTU-CVE-2026-104827

## What is CVE-2026-104827?

CVE-2026-104827 is a high-severity denial of service vulnerability in reactphp http, published on 15 Oct 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

react/http is an event-driven, streaming HTTP client and server implementation for ReactPHP. From 1.0.0 until 1.11.1, React\Http\Browser uses ClientRequestStream::handleData() to append response-header bytes to an internal buffer without enforcing a size limit. A remote server can send a valid status line and partial header, withhold the \r\n\r\n or \n\n header terminator, and continue streaming data so the buffer grows for the life of the connection. Applications that fetch attacker-controlled or attacker-influenced URLs, including URLs reached through redirects, can exhaust PHP memory_limit and crash the event-loop or worker process. Confidentiality and integrity are unaffected. This issue is fixed in version 1.11.1.

Weakness: CWE-770 (Allocation of Resources Without Limits or Throttling)

## Which versions are affected by CVE-2026-104827?

2 open source packages ship an affected version, including react/http.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `react/http` | Packagist | From 1.0.0 | 1.11.1 |
| `react/http` | Packagist | From 1.0.0 | 1.11.1 |

## How do I fix CVE-2026-104827?

Upgrade react/http to 1.11.1 or later.

## Is CVE-2026-104827 being exploited?

There is no known exploitation of CVE-2026-104827 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-104827 and fix it if it is affected.

What it is: CVE-2026-104827 is a high-severity denial of service vulnerability in reactphp http, published on 15 Oct 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-104827 in the wild and no public exploit code.

Affected packages and fixed versions:
- react/http (Packagist): affected from 1.0.0; fixed in 1.11.1
- react/http (Packagist): affected from 1.0.0; fixed in 1.11.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-104827/ (Markdown: https://insights.sbomify.com/CVE-2026-104827/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-104827
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-104827
- OSV: https://osv.dev/vulnerability/CVE-2026-104827

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-104827/
Summaries are generated and may contain mistakes; the official description above is the record.
