# CVE-2026-104843: uv: Path traversal on Windows through wheel extraction

> Attackers can write executable files outside the installation directory on Windows via malicious wheels, potentially leading to code execution.

- **Severity:** Medium 5.9 (`CVSS:4.0/AV:N/AC:L/AT:P/PR:N/UI:A/VC:N/VI:H/VA:N/SC:N/SI:N/SA:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 2 Oct 2026
- **Updated:** 2 Oct 2026
- **Also known as:** GHSA-2cv4-cqwr-gwf7, MINI-vw9h-ghgq-j4vj, PYSEC-2026-4305, UBUNTU-CVE-2026-104843

## What is CVE-2026-104843?

CVE-2026-104843 is a medium-severity path traversal vulnerability in astral-sh uv, published on 2 Oct 2026. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

### Official description

uv is a Python package and project manager written in Rust. From 0.12.7 until 0.12.18, uv wheel extraction on Windows can process a malicious wheel in a way that writes a file outside the installation prefix, including an executable in a directory already present on the user's PATH. Non-Windows hosts are not affected. This issue is fixed in version 0.12.18.

Weakness: CWE-22 (Improper Limitation of a Pathname to a Restricted Directory)

## Which versions are affected by CVE-2026-104843?

5 open source packages ship an affected version, including uv.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `uv` | PyPI | From 0.12.7 | 0.12.18 |
| `uv` | PyPI | From 0.12.7 | 0.12.18 |
| `uv` | PyPI | From 0.12.7 | 0.12.18 |
| `uv` | crates.io | From 0.12.7 | 0.12.18 |
| `uv` | crates.io | From 0.12.7 | 0.12.18 |

## How do I fix CVE-2026-104843?

Upgrade uv to 0.12.18 or later.

## Is CVE-2026-104843 being exploited?

There is no known exploitation of CVE-2026-104843 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-104843 and fix it if it is affected.

What it is: CVE-2026-104843 is a medium-severity path traversal vulnerability in astral-sh uv, published on 2 Oct 2026. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2026-104843 in the wild and no public exploit code.

Affected packages and fixed versions:
- uv (PyPI): affected from 0.12.7; fixed in 0.12.18
- uv (PyPI): affected from 0.12.7; fixed in 0.12.18
- uv (PyPI): affected from 0.12.7; fixed in 0.12.18
- uv (crates.io): affected from 0.12.7; fixed in 0.12.18
- uv (crates.io): affected from 0.12.7; fixed in 0.12.18

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-104843/ (Markdown: https://insights.sbomify.com/CVE-2026-104843/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-104843
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-104843
- OSV: https://osv.dev/vulnerability/CVE-2026-104843

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-104843/
Summaries are generated and may contain mistakes; the official description above is the record.
