CVE-2026-104844 PostCSS: Quadratic complexity in flat selector parsing allows CPU exhaustion
A crafted CSS selector causes quadratic complexity in PostCSS Selector Parser, leading to CPU exhaustion and denial of service in synchronous parsing contexts.
- Exploited in the wild
- Not known
- Login needed
- Not needed
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2026-104844?
CVE-2026-104844 is a medium-severity denial of service vulnerability in postcss-selector-parser, published on 2 Oct 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Official description
PostCSS Selector Parser is a CSS selector parser that integrates with PostCSS but does not require it. Prior to 7.1.6, src/parser.js splitWord() can receive a flat selector as one word token carrying many class or ID indexes because period and hash characters are not tokenizer word delimiters. The uniqs() deduplication and per-index class and ID membership checks repeatedly scan the class and ID index arrays, while a separate Sass-interpolation filtering pass also performs repeated linear scanning. Together, these passes make parsing quadratic in the number of indexes and allow a crafted selector to occupy a synchronous parser thread. The maxNestingDepth guard does not mitigate the issue because the hostile selector can have zero nesting depth. Only consumers that synchronously parse untrusted selectors in an exposed request path are affected; ordinary build-time parsing of trusted sources is not affected. This issue is fixed in version 7.1.6.
Which versions are affected by CVE-2026-104844?
4 open source packages ship an affected version, including postcss-selector-parser.
| Package | Affected | Fixed in |
|---|---|---|
postcss-selector-parser npm | All versions | 6.1.5 |
postcss-selector-parser npm | All versions | 6.1.5 |
postcss-selector-parser npm | From 7.0.0 | 7.1.6 |
postcss-selector-parser npm | From 7.0.0 | 7.1.6 |
Linux distribution packages (1)
git-bug openSUSE:Tumbleweed | All versions | 0.11.0-2.1 |
How do I fix CVE-2026-104844?
Upgrade postcss-selector-parser to a fixed version for your release line: 6.1.5 or 7.1.6.
Upgrade, then put limits on request size, rate and nesting depth so one client cannot exhaust the service. More about Denial of service.
Is CVE-2026-104844 being exploited?
There is no known exploitation of CVE-2026-104844 in the wild and no public exploit code.
Sources
Also known as CLEANSTART-2026-BO15897, CLEANSTART-2026-FR22195, CLEANSTART-2026-OB13388, CLEANSTART-2026-ZC15270, CLEANSTART-2026-ZS54196, CLSA-2026-1791278836 and 15 more.