# CVE-2026-104844: PostCSS: Quadratic complexity in flat selector parsing allows CPU exhaustion

> A crafted CSS selector causes quadratic complexity in PostCSS Selector Parser, leading to CPU exhaustion and denial of service in synchronous parsing contexts.

- **Severity:** Medium 5.9 (`CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:N/I:N/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 2 Oct 2026
- **Updated:** 2 Oct 2026
- **Also known as:** CLEANSTART-2026-BO15897, CLEANSTART-2026-FR22195, CLEANSTART-2026-OB13388, CLEANSTART-2026-ZC15270, CLEANSTART-2026-ZS54196, CLSA-2026-1791278836, CLSA-2026-1792473324, CLSA-2026-1792489723, CLSA-2026-1792489741, CLSA-2026-1792489830, ECHO-e536-c6d0-c60b, GHSA-rj75-hqrm-r3gf, MINI-3qv8-76cw-pmq4, MINI-7229-49f3-p778, MINI-cv9q-3qg8-9g97, MINI-p3x2-vgjw-gmhj, MINI-pcvc-fqm6-89qr, MINI-pqw4-276j-9x9v, MINI-vm8p-rv29-8c2w, MINI-wgv8-rrf7-mp75, openSUSE-SU-2026:12083-1

## What is CVE-2026-104844?

CVE-2026-104844 is a medium-severity denial of service vulnerability in postcss-selector-parser, published on 2 Oct 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

PostCSS Selector Parser is a CSS selector parser that integrates with PostCSS but does not require it. Prior to 7.1.6, src/parser.js splitWord() can receive a flat selector as one word token carrying many class or ID indexes because period and hash characters are not tokenizer word delimiters. The uniqs() deduplication and per-index class and ID membership checks repeatedly scan the class and ID index arrays, while a separate Sass-interpolation filtering pass also performs repeated linear scanning. Together, these passes make parsing quadratic in the number of indexes and allow a crafted selector to occupy a synchronous parser thread. The maxNestingDepth guard does not mitigate the issue because the hostile selector can have zero nesting depth. Only consumers that synchronously parse untrusted selectors in an exposed request path are affected; ordinary build-time parsing of trusted sources is not affected. This issue is fixed in version 7.1.6.

Weakness: CWE-407 (Inefficient Algorithmic Complexity), CWE-400 (Uncontrolled Resource Consumption)

## Which versions are affected by CVE-2026-104844?

4 open source packages ship an affected version, including postcss-selector-parser.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `postcss-selector-parser` | npm | All versions | 6.1.5 |
| `postcss-selector-parser` | npm | All versions | 6.1.5 |
| `postcss-selector-parser` | npm | From 7.0.0 | 7.1.6 |
| `postcss-selector-parser` | npm | From 7.0.0 | 7.1.6 |
| `git-bug` | openSUSE:Tumbleweed | All versions | 0.11.0-2.1 |

## How do I fix CVE-2026-104844?

Upgrade postcss-selector-parser to a fixed version for your release line: 6.1.5 or 7.1.6.

## Is CVE-2026-104844 being exploited?

There is no known exploitation of CVE-2026-104844 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-104844 and fix it if it is affected.

What it is: CVE-2026-104844 is a medium-severity denial of service vulnerability in postcss-selector-parser, published on 2 Oct 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-104844 in the wild and no public exploit code.

Affected packages and fixed versions:
- postcss-selector-parser (npm): affected all versions; fixed in 6.1.5
- postcss-selector-parser (npm): affected all versions; fixed in 6.1.5
- postcss-selector-parser (npm): affected from 7.0.0; fixed in 7.1.6
- postcss-selector-parser (npm): affected from 7.0.0; fixed in 7.1.6

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-104844/ (Markdown: https://insights.sbomify.com/CVE-2026-104844/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-104844
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-104844
- OSV: https://osv.dev/vulnerability/CVE-2026-104844

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-104844/
Summaries are generated and may contain mistakes; the official description above is the record.
