# CVE-2026-104847: ProseMirror: XSS vulnerability in prosemirror-view's paste handling

> Attackers can execute arbitrary JavaScript in a user's browser by crafting HTML with unvalidated attributes that bypass schema validation during paste operations in ProseMirror editors.

- **Severity:** High 8.5 (`CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:A/VC:H/VI:H/VA:N/SC:N/SI:N/SA:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 2 Oct 2026
- **Updated:** 2 Oct 2026
- **Also known as:** ECHO-6adb-f707-8d52, GHSA-c8x8-7fp4-3x9w, MINI-2x3r-qwf7-m9mx, ROOT-APP-NPM-CVE-2026-104847

## What is CVE-2026-104847?

CVE-2026-104847 is a high-severity cross-site scripting vulnerability in prosemirror-view, published on 2 Oct 2026. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

### Official description

ProseMirror's view component renders and manages the editable browser interface for ProseMirror documents. Prior to 1.42.3, prosemirror-view paste handling accepts attacker-provided HTML whose clipboard slice context contains attributes that are not passed through schema attribute validation. When a user pastes the crafted HTML into an editor, the unvalidated context attributes can construct content that executes attacker-controlled JavaScript in the browser window containing the editor. This issue is fixed in version 1.42.3.

Weakness: CWE-79 (Improper Neutralization of Input During Web Page Generation)

## Which versions are affected by CVE-2026-104847?

2 open source packages ship an affected version, including prosemirror-view.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `prosemirror-view` | npm | All versions | 1.42.3 |
| `prosemirror-view` | npm | All versions | 1.42.3 |

## How do I fix CVE-2026-104847?

Upgrade prosemirror-view to 1.42.3 or later.

## Is CVE-2026-104847 being exploited?

There is no known exploitation of CVE-2026-104847 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-104847 and fix it if it is affected.

What it is: CVE-2026-104847 is a high-severity cross-site scripting vulnerability in prosemirror-view, published on 2 Oct 2026. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2026-104847 in the wild and no public exploit code.

Affected packages and fixed versions:
- prosemirror-view (npm): affected all versions; fixed in 1.42.3
- prosemirror-view (npm): affected all versions; fixed in 1.42.3

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-104847/ (Markdown: https://insights.sbomify.com/CVE-2026-104847/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-104847
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-104847
- OSV: https://osv.dev/vulnerability/CVE-2026-104847

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-104847/
Summaries are generated and may contain mistakes; the official description above is the record.
