# CVE-2026-104873: LangGraph SDK custom auth silently ignores actions= on resource decorators

> Authenticated users can bypass action-specific authorization checks in LangGraph SDK decorators, allowing unauthorized access to other users' resources.

- **Severity:** High 7.6 (`CVSS:4.0/AV:N/AC:L/AT:P/PR:L/UI:N/VC:H/VI:H/VA:N/SC:N/SI:N/SA:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 2 Oct 2026
- **Updated:** 5 Oct 2026
- **Also known as:** ECHO-af4a-f4a1-bc1c, GHSA-fvww-7h3r-vfhp, PYSEC-2026-4240, ROOT-APP-PYPI-CVE-2026-104873, openSUSE-SU-2026:12279-1

## What is CVE-2026-104873?

CVE-2026-104873 is a high-severity missing authorization vulnerability in langchain-ai langgraph, published on 2 Oct 2026. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

LangGraph Python SDK is used to connect to running LangGraph API servers, manage assistants, threads and stream runs from Python applications. From 0.1.45 until 0.4.4, the langgraph-sdk resource-scoped authorization decorators @auth.on.threads, @auth.on.assistants, and @auth.on.crons ignore the actions argument and register the selected handler for every action on the resource. Because that wildcard resource handler is selected before broader fallback handlers, an authenticated user may bypass fallback action, ownership, or permission checks and read, update, or delete another user's resource. Only Python deployments using actions on the affected decorators are vulnerable, and a deployment remains protected when the selected handler independently enforces all required checks for every action it receives. This issue is fixed in version 0.4.4.

Weakness: CWE-863 (Incorrect Authorization)

## Which versions are affected by CVE-2026-104873?

3 open source packages ship an affected version, including langgraph-sdk.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `langgraph-sdk` | PyPI | From 0.1.45 | 0.4.4 |
| `langgraph-sdk` | PyPI | From 0.1.45 | 0.4.4 |
| `langgraph-sdk` | PyPI | From 0.1.45 | 0.4.4 |
| `python-langgraph-sdk` | openSUSE:Tumbleweed | All versions | 0.4.9-1.1 |

## How do I fix CVE-2026-104873?

Upgrade langgraph-sdk to 0.4.4 or later.

## Is CVE-2026-104873 being exploited?

There is no known exploitation of CVE-2026-104873 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-104873 and fix it if it is affected.

What it is: CVE-2026-104873 is a high-severity missing authorization vulnerability in langchain-ai langgraph, published on 2 Oct 2026. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-104873 in the wild and no public exploit code.

Affected packages and fixed versions:
- langgraph-sdk (PyPI): affected from 0.1.45; fixed in 0.4.4
- langgraph-sdk (PyPI): affected from 0.1.45; fixed in 0.4.4
- langgraph-sdk (PyPI): affected from 0.1.45; fixed in 0.4.4

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-104873/ (Markdown: https://insights.sbomify.com/CVE-2026-104873/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-104873
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-104873
- OSV: https://osv.dev/vulnerability/CVE-2026-104873

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-104873/
Summaries are generated and may contain mistakes; the official description above is the record.
