CVE-2026-104874 Multidict: Reference leak in CIMultiDict/MultiDict items-view union and subtraction
Attackers can cause unbounded memory growth and denial of service by triggering reference leaks in specific multidict operations.
- Exploited in the wild
- Not known
- Login needed
- Not needed
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2026-104874?
CVE-2026-104874 is a medium-severity denial of service vulnerability in aio-libs multidict, published on 2 Oct 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Official description
Multidict is an implementation of a multidict data structure. From 6.7.0 until 6.9.1, the C extension's items-view reflected union operation, operand | d.items(), in multidict_itemsview_or2_impl and subtraction operation, d.items() - operand, in multidict_itemsview_sub1_impl fail to release new key-identity and value references returned for each operand element. Applications that perform these operations over attacker-influenced sequences can leak two strong references per element, and garbage collection cannot reclaim them, so repeated operations can cause unbounded process memory growth and denial of service. Forward union, intersection, non-tuple operand elements, and pure-Python builds are not affected by this reference leak. This issue is fixed in version 6.9.1.
Weakness: CWE-401
Which versions are affected by CVE-2026-104874?
3 open source packages ship an affected version, including multidict.
| Package | Affected | Fixed in |
|---|---|---|
multidict PyPI | From 6.7.0 | 6.9.1 |
multidict PyPI | From 6.7.0 | 6.9.1 |
multidict PyPI | From 6.7.0 | 6.9.1 |
Linux distribution packages (1)
python-multidict openSUSE:Tumbleweed | All versions | 7.0.0-1.1 |
How do I fix CVE-2026-104874?
Upgrade multidict to 6.9.1 or later.
Upgrade, then put limits on request size, rate and nesting depth so one client cannot exhaust the service. More about Denial of service.
Is CVE-2026-104874 being exploited?
It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-104874 exists.
Sources
Also known as CLEANSTART-2026-YA90278, ECHO-4642-8da4-6164, GHSA-54p9-h82j-f925, MINI-2mj5-v592-8p4f, MINI-498w-x5rh-23jf, MINI-4gjq-gmvh-7fmv and 29 more.