# CVE-2026-104890: Kunstmaan CMS: MediaBundle extension blacklist bypass allows authenticated administrators to upload executable PHP files leading to remote code execution

> Authenticated administrators can bypass file extension blacklists to upload executable PHP files, resulting in remote code execution.

- **Severity:** High 7.2 (`CVSS:3.1/AV:N/AC:L/PR:H/UI:N/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** An administrator
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 5 Oct 2026
- **Updated:** 7 Oct 2026
- **Also known as:** GHSA-p279-5wcv-45vq

## What is CVE-2026-104890?

CVE-2026-104890 is a high-severity vulnerability in KunstmaanBundlesCMS, published on 5 Oct 2026. An attacker needs administrator access to exploit it, with no action from the victim.

### Official description

Kunstmaan CMS is an open source content management system based on the Symfony framework. Prior to 7.3.2, src/Kunstmaan/MediaBundle/Helper/File/FileHandler.php performs the blacklisted_extensions check case-sensitively in FileHandler::getFilePath and lowercases the stored extension afterward. An authenticated backend user with media access can upload a mixed-case executable extension such as PHP that bypasses the check and is stored in the web-accessible media directory with an executable lowercase extension. The default blacklist also omits several server-executable extension types, allowing the same code-execution impact where the web server executes uploaded files. This issue is fixed in version 7.3.2.

Weakness: CWE-434 (Unrestricted Upload of File with Dangerous Type)

## Which versions are affected by CVE-2026-104890?

4 open source packages ship an affected version, including kunstmaan/bundles-cms and kunstmaan/media-bundle.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `kunstmaan/bundles-cms` | Packagist | All versions | 7.3.2 |
| `kunstmaan/bundles-cms` | Packagist | All versions | 7.3.2 |
| `kunstmaan/media-bundle` | Packagist | All versions | 7.3.2 |
| `kunstmaan/media-bundle` | Packagist | All versions | 7.3.2 |

## How do I fix CVE-2026-104890?

Upgrade kunstmaan/bundles-cms to 7.3.2 or later.

## Is CVE-2026-104890 being exploited?

There is no known exploitation of CVE-2026-104890 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-104890 and fix it if it is affected.

What it is: CVE-2026-104890 is a high-severity vulnerability in KunstmaanBundlesCMS, published on 5 Oct 2026. An attacker needs administrator access to exploit it, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-104890 in the wild and no public exploit code.

Affected packages and fixed versions:
- kunstmaan/bundles-cms (Packagist): affected all versions; fixed in 7.3.2
- kunstmaan/bundles-cms (Packagist): affected all versions; fixed in 7.3.2
- kunstmaan/media-bundle (Packagist): affected all versions; fixed in 7.3.2
- kunstmaan/media-bundle (Packagist): affected all versions; fixed in 7.3.2

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-104890/ (Markdown: https://insights.sbomify.com/CVE-2026-104890/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-104890
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-104890
- OSV: https://osv.dev/vulnerability/CVE-2026-104890

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-104890/
Summaries are generated and may contain mistakes; the official description above is the record.
