# CVE-2026-104892: Plane: Plaintext logging of API token

> Attackers with low privileges can steal user API keys from plaintext logs, enabling privilege escalation in the Plane project management tool.

- **Severity:** High 8.7 (`CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:N/VC:H/VI:H/VA:L/SC:N/SI:N/SA:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** No
- **Published:** 5 Oct 2026
- **Updated:** 5 Oct 2026
- **Also known as:** GHSA-r5p8-cj3q-38cc

## What is CVE-2026-104892?

CVE-2026-104892 is a high-severity vulnerability in makeplane plane, published on 5 Oct 2026. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

Plane is an open-source project management tool. Prior to 1.4.0, aPITokenLogMiddleware logs API keys in plaintext. This allows someone with low privileges to steal user API keys and further escalate their privileges. This issue is fixed in 1.4.0.

Weakness: CWE-256 (Plaintext Storage of a Password)

## Which versions are affected by CVE-2026-104892?


## How do I fix CVE-2026-104892?

No fix has been published for CVE-2026-104892 yet. Limit exposure of the affected software until one is available.

## Is CVE-2026-104892 being exploited?

There is no known exploitation of CVE-2026-104892 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-104892 and fix it if it is affected.

What it is: CVE-2026-104892 is a high-severity vulnerability in makeplane plane, published on 5 Oct 2026. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-104892 in the wild and no public exploit code.

Affected product: makeplane plane. No package-level version data is available, so check the vendor advisory linked from the reference page.

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-104892/ (Markdown: https://insights.sbomify.com/CVE-2026-104892/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-104892
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-104892
- OSV: https://osv.dev/vulnerability/CVE-2026-104892

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-104892/
Summaries are generated and may contain mistakes; the official description above is the record.
