# CVE-2026-104894: Plane: Cross-Tenant Module Issue Linking via IDOR

> Authenticated users can link issues from other workspaces to their own modules due to missing ownership validation, allowing cross-tenant data manipulation.

- **Severity:** Medium 4.3 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:L/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** No
- **Published:** 5 Oct 2026
- **Updated:** 5 Oct 2026
- **Also known as:** GHSA-x5c5-hmvm-94v9

## What is CVE-2026-104894?

CVE-2026-104894 is a medium-severity missing authorization vulnerability in makeplane plane, published on 5 Oct 2026. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

Plane is an open-source project management tool. Prior to 1.4.0, the modules endpoint accepts issue UUIDs in the URL path without validating that they belong to the caller's workspace. An authenticated user can link issues from any workspace to modules in their own workspace. This issue is fixed in 1.4.0.

Weakness: CWE-639 (Authorization Bypass Through User-Controlled Key)

## Which versions are affected by CVE-2026-104894?


## How do I fix CVE-2026-104894?

No fix has been published for CVE-2026-104894 yet. Limit exposure of the affected software until one is available.

## Is CVE-2026-104894 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-104894 exists.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-104894 and fix it if it is affected.

What it is: CVE-2026-104894 is a medium-severity missing authorization vulnerability in makeplane plane, published on 5 Oct 2026. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-104894 exists.

Affected product: makeplane plane. No package-level version data is available, so check the vendor advisory linked from the reference page.

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-104894/ (Markdown: https://insights.sbomify.com/CVE-2026-104894/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-104894
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-104894
- OSV: https://osv.dev/vulnerability/CVE-2026-104894

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-104894/
Summaries are generated and may contain mistakes; the official description above is the record.
