{"answers":{"affected":"","exploited":"It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-104982 exists.","fix":"No fix has been published for CVE-2026-104982 yet. Limit exposure of the affected software until one is available.","what":"CVE-2026-104982 is a medium-severity path traversal vulnerability in Linux Mint Xreader, published on 3 Oct 2026. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link."},"fix_prompt":"Check this codebase for CVE-2026-104982 and fix it if it is affected.\n\nWhat it is: CVE-2026-104982 is a medium-severity path traversal vulnerability in Linux Mint Xreader, published on 3 Oct 2026. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.\nExploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-104982 exists.\n\nAffected product: Linux Mint Xreader. No package-level version data is available, so check the vendor advisory linked from the reference page.\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2026-104982/ (Markdown: https://insights.sbomify.com/CVE-2026-104982/index.md)","id":"CVE-2026-104982","markdown":"https://insights.sbomify.com/CVE-2026-104982/index.md","name":"CVE-2026-104982","record":{"aliases":["GHSA-5m53-wrr5-57qq"],"analysis":{"component_type":"desktop_application","fix_type":"upgrade","impacts":["data_read","code_execution"],"network_reachable":"yes","non_default_config":false,"product_category":"Linux Mint Xreader","requires_auth":"none","summary":"Remote attackers can exploit a path traversal flaw in the EPUB handler to read arbitrary files or execute code via malicious EPUB files.","user_interaction":"required","vuln_class":"path_traversal"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"VulDB","cpe":[],"cvss":{"score":5.3,"severity":"medium","source":"cna","vector":"CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:P/VC:L/VI:N/VA:N/SC:N/SI:N/SA:N/E:P","version":"4.0"},"cwes":[{"id":"CWE-22","name":"Improper Limitation of a Pathname to a Restricted Directory"}],"description":"A flaw has been found in Linux Mint Xreader up to 4.6.5. This issue affects the function setup_document_content_list/g_strdup_printf of the file backend/epub/epub-document.c of the component EPUB File Handler. This manipulation causes path traversal. The attack is possible to be carried out remotely. The exploit has been published and may be used. Upgrading to version 4.6.6 is capable of addressing this issue. Patch name: a5aecea074e8564b7a22f1ce054b31ec862974b7. It is advisable to upgrade the affected component. One of the project maintainers explains, that \"EPUB support was removed from Xreader and reimplemented in Xepub\".","ecosystems":[],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"weaponised"},"has_fix":false,"headline":"Linux Mint Xreader EPUB File epub-document.c g_strdup_printf path traversal","id":"CVE-2026-104982","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":null,"product":null,"products":[],"type":"path_traversal","year":"2026"},"n_packages":0,"n_references":8,"next":{"headline":"Linux Mint Xreader PDF Attachment Saving ev-window.c g_file_get_child path traversal","id":"CVE-2026-104983"},"packages":[],"prev":{"headline":"Plane: Cross-tenant stored XSS in intake enables account takeover","id":"CVE-2026-104979"},"products":["Xreader"],"published":"2026-10-03","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"poc","technical_impact":"partial"},"state":"PUBLISHED","updated":"2026-10-06","vendors":["Linux Mint"]},"summary":"Remote attackers can exploit a path traversal flaw in the EPUB handler to read arbitrary files or execute code via malicious EPUB files.","url":"https://insights.sbomify.com/CVE-2026-104982/"}