{"answers":{"affected":"","exploited":"It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-104983 exists.","fix":"No fix published yet.","what":"CVE-2026-104983 is a medium-severity path traversal vulnerability in Linux Mint Xreader, published on 3 Oct 2026. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link."},"fix_prompt":"Check this codebase for CVE-2026-104983 and fix it if it is affected.\n\nWhat it is: CVE-2026-104983 is a medium-severity path traversal vulnerability in Linux Mint Xreader, published on 3 Oct 2026. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.\nExploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-104983 exists.\n\nAffected product: Linux Mint Xreader. No package-level version data is available, so check the vendor advisory linked from the reference page.\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2026-104983/ (Markdown: https://insights.sbomify.com/CVE-2026-104983/index.md)","id":"CVE-2026-104983","markdown":"https://insights.sbomify.com/CVE-2026-104983/index.md","name":"CVE-2026-104983","record":{"aliases":["GHSA-63c6-qprh-g95r","openSUSE-SU-2026:12077-1"],"analysis":{"component_type":"desktop_application","fix_type":"no_fix_stated","impacts":["data_read","data_modify"],"network_reachable":"yes","non_default_config":false,"product_category":"Linux Mint Xreader","requires_auth":"none","summary":"Remote attackers can exploit a path traversal flaw in Xreader's PDF attachment saving to read or modify arbitrary files.","user_interaction":"required","vuln_class":"path_traversal"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"VulDB","cpe":[],"cvss":{"score":5.3,"severity":"medium","source":"cna","vector":"CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:P/VC:L/VI:L/VA:L/SC:N/SI:N/SA:N/E:P","version":"4.0"},"cwes":[{"id":"CWE-22","name":"Improper Limitation of a Pathname to a Restricted Directory"}],"description":"A vulnerability has been found in Linux Mint Xreader up to 4.6.9. Impacted is the function g_file_get_child of the file shell/ev-window.c of the component PDF Attachment Saving Handler. Such manipulation of the argument attachment leads to path traversal. The attack may be performed from remote. The exploit has been disclosed to the public and may be used. One of the project maintainers closed this issue as \"completed\", because \"EPUB support was removed from Xreader and reimplemented in Xepub\". Code analysis indicates that this might be a misunderstanding of the situation.","ecosystems":["openSUSE:Tumbleweed"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"weaponised"},"has_fix":true,"headline":"Linux Mint Xreader PDF Attachment Saving ev-window.c g_file_get_child path traversal","id":"CVE-2026-104983","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":null,"product":null,"products":[],"type":"path_traversal","year":"2026"},"n_packages":1,"n_references":6,"next":{"headline":"Auth bypass in Red Hat Certificate System 10","id":"CVE-2026-104988"},"packages":[{"ecosystem":"openSUSE:Tumbleweed","fixed":["4.6.9-2.1"],"introduced":["0"],"last_affected":[],"package":"xreader","purl":"pkg:rpm/opensuse/xreader\u0026distro=openSUSE%20Tumbleweed","source":"openSUSE-SU-2026:12077-1"}],"prev":{"headline":"Linux Mint Xreader EPUB File epub-document.c g_strdup_printf path traversal","id":"CVE-2026-104982"},"products":["Xreader"],"published":"2026-10-03","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"SUSE","prefix":"openSUSE"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"poc","technical_impact":"partial"},"state":"PUBLISHED","updated":"2026-10-05","vendors":["Linux Mint"]},"summary":"Remote attackers can exploit a path traversal flaw in Xreader's PDF attachment saving to read or modify arbitrary files.","url":"https://insights.sbomify.com/CVE-2026-104983/"}