CVE-2026-10514 1Panel-dev CordysCRM RequestParamTrimConfig.java cross site scripting

Medium 4.8 Published Updated
Exploited in the wild
Not known
Fix
None listed

What is CVE-2026-10514?

CVE-2026-10514 is a medium-severity vulnerability in 1Panel-dev CordysCRM, published on 1 Jun 2026.

Official description

A vulnerability has been found in 1Panel-dev CordysCRM up to 1.6.2. This affects an unknown function of the file backend/framework/src/main/java/cn/cordys/config/RequestParamTrimConfig.java. The manipulation leads to cross site scripting. Remote exploitation of the attack is possible. The exploit has been disclosed to the public and may be used. Upgrading to version 1.7.0 mitigates this issue. The identifier of the patch is c87682afa8df79853299f75489c9d333f7bc5fce. It is suggested to upgrade the affected component.

Weakness: CWE-94, CWE-79

Which versions are affected by CVE-2026-10514?

How do I fix CVE-2026-10514?

No fix has been published for CVE-2026-10514 yet. Limit exposure of the affected software until one is available.

Is CVE-2026-10514 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-10514 exists.

Sources

Also known as GHSA-vj33-v6j8-4qw8.

Is CVE-2026-10514 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free