{"answers":{"affected":"","exploited":"It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-10514 exists.","fix":"No fix has been published for CVE-2026-10514 yet. Limit exposure of the affected software until one is available.","what":"CVE-2026-10514 is a medium-severity vulnerability in 1Panel-dev CordysCRM, published on 1 Jun 2026."},"fix_prompt":"Check this codebase for CVE-2026-10514 and fix it if it is affected.\n\nWhat it is: CVE-2026-10514 is a medium-severity vulnerability in 1Panel-dev CordysCRM, published on 1 Jun 2026. \nExploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-10514 exists.\n\nAffected product: 1Panel-dev CordysCRM. No package-level version data is available, so check the vendor advisory linked from the reference page.\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2026-10514/ (Markdown: https://insights.sbomify.com/CVE-2026-10514/index.md)","id":"CVE-2026-10514","markdown":"https://insights.sbomify.com/CVE-2026-10514/index.md","name":"CVE-2026-10514","record":{"aliases":["GHSA-vj33-v6j8-4qw8"],"analysis":null,"analysis_generated_by":null,"assigner":"VulDB","cpe":[],"cvss":{"score":4.8,"severity":"medium","source":"cna","vector":"CVSS:4.0/AV:N/AC:L/AT:N/PR:H/UI:P/VC:N/VI:L/VA:N/SC:N/SI:N/SA:N/E:P","version":"4.0"},"cwes":[{"id":"CWE-94","name":"Improper Control of Generation of Code"},{"id":"CWE-79","name":"Improper Neutralization of Input During Web Page Generation"}],"description":"A vulnerability has been found in 1Panel-dev CordysCRM up to 1.6.2. This affects an unknown function of the file backend/framework/src/main/java/cn/cordys/config/RequestParamTrimConfig.java. The manipulation leads to cross site scripting. Remote exploitation of the attack is possible. The exploit has been disclosed to the public and may be used. Upgrading to version 1.7.0 mitigates this issue. The identifier of the patch is c87682afa8df79853299f75489c9d333f7bc5fce. It is suggested to upgrade the affected component.","ecosystems":[],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"weaponised"},"has_fix":false,"headline":"1Panel-dev CordysCRM RequestParamTrimConfig.java cross site scripting","id":"CVE-2026-10514","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":null,"product":null,"products":[],"type":null,"year":"2026"},"n_packages":0,"n_references":9,"next":{"headline":"Claircore: Unauthenticated attackers can submit manifests with URIs pointing to internal services or cloud metadata endpoints","id":"CVE-2026-10517"},"packages":[],"prev":{"headline":"Webmention \u003c= 5.8.0 - Unauthenticated Stored Cross-Site Scripting via MF2 'photo'/'url' Author Properties","id":"CVE-2026-10513"},"products":["CordysCRM"],"published":"2026-06-01","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"poc","technical_impact":"partial"},"state":"PUBLISHED","updated":"2026-06-02","vendors":["1Panel-dev"]},"summary":null,"url":"https://insights.sbomify.com/CVE-2026-10514/"}