# CVE-2026-10514: 1Panel-dev CordysCRM RequestParamTrimConfig.java cross site scripting


- **Severity:** Medium 4.8 (`CVSS:4.0/AV:N/AC:L/AT:N/PR:H/UI:P/VC:N/VI:L/VA:N/SC:N/SI:N/SA:N/E:P`)
- **Exploited in the wild:** Not known
- **Fix available:** No
- **Published:** 1 Jun 2026
- **Updated:** 2 Jun 2026
- **Also known as:** GHSA-vj33-v6j8-4qw8

## What is CVE-2026-10514?

CVE-2026-10514 is a medium-severity vulnerability in 1Panel-dev CordysCRM, published on 1 Jun 2026. 

### Official description

A vulnerability has been found in 1Panel-dev CordysCRM up to 1.6.2. This affects an unknown function of the file backend/framework/src/main/java/cn/cordys/config/RequestParamTrimConfig.java. The manipulation leads to cross site scripting. Remote exploitation of the attack is possible. The exploit has been disclosed to the public and may be used. Upgrading to version 1.7.0 mitigates this issue. The identifier of the patch is c87682afa8df79853299f75489c9d333f7bc5fce. It is suggested to upgrade the affected component.

Weakness: CWE-94 (Improper Control of Generation of Code), CWE-79 (Improper Neutralization of Input During Web Page Generation)

## Which versions are affected by CVE-2026-10514?


## How do I fix CVE-2026-10514?

No fix has been published for CVE-2026-10514 yet. Limit exposure of the affected software until one is available.

## Is CVE-2026-10514 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-10514 exists.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-10514 and fix it if it is affected.

What it is: CVE-2026-10514 is a medium-severity vulnerability in 1Panel-dev CordysCRM, published on 1 Jun 2026. 
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-10514 exists.

Affected product: 1Panel-dev CordysCRM. No package-level version data is available, so check the vendor advisory linked from the reference page.

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-10514/ (Markdown: https://insights.sbomify.com/CVE-2026-10514/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-10514
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-10514
- OSV: https://osv.dev/vulnerability/CVE-2026-10514

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-10514/
Summaries are generated and may contain mistakes; the official description above is the record.
