CVE-2026-10518 Incorrect Authorization in GitLab

Medium 4.3 Published Updated

Authenticated guest users can read private security policy content due to improper authorization enforcement in GitLab EE.

Exploited in the wild
Not known
Login needed
Any signed-in user
Attackable
Over the internet
Victim action needed
Not needed
Fix
Available

What is CVE-2026-10518?

CVE-2026-10518 is a medium-severity missing authorization vulnerability in Gitlab Gitlab, published on 29 Sep 2026. Any signed-in user can exploit it over the network, with no action from the victim.

Official description

GitLab has remediated an issue in GitLab EE affecting all versions from 17.9 before 19.2.7, 19.3 before 19.3.3, and 19.4 before 19.4.1 that under certain conditions could have allowed an authenticated user with guest-level permissions to read private security policy content they were not authorized to access due to improper authorization enforcement.

Weakness: CWE-863

Which versions are affected by CVE-2026-10518?

1 open source package ship an affected version, including gitlab. It affects 1 product.

PackageAffectedFixed in
gitlab BitnamiFrom 17.9.019.2.7, 19.3.3, 19.4.1

Products include Gitlab Gitlab.

How do I fix CVE-2026-10518?

Upgrade gitlab to a fixed version for your release line: 19.2.7, 19.3.3 or 19.4.1.

Upgrade, and check permissions on every request on the server, not only in the interface. More about Missing authorization.

Is CVE-2026-10518 being exploited?

There is no known exploitation of CVE-2026-10518 in the wild and no public exploit code.

All Gitlab Gitlab vulnerabilities

Sources

Also known as BIT-gitlab-2026-10518, GHSA-r9w4-9vh4-q9m8, MINI-752f-cxvj-97c9, MINI-jgpf-6pp8-95r8, MINI-m98c-7vhm-hp37.

Is CVE-2026-10518 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free