# CVE-2026-105299: Summary Before version 0.9.0, the HTTP/1 upstream path in pingora-proxy passed the downstream request through upstream_request_filter and wr


- **Severity:** High 8.7 (`CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:C/C:H/I:H/A:N`)
- **Exploited in the wild:** Not known
- **Fix available:** Yes
- **Published:** 20 Oct 2026
- **Updated:** 20 Oct 2026
- **Also known as:** GHSA-r9g2-75m7-w9wg, GHSA-vx4q-2c55-cvmg, RUSTSEC-2026-0390

## What is CVE-2026-105299?

CVE-2026-105299 is a high-severity vulnerability in https://github.com/cloudflare/pingora, published on 20 Oct 2026. 

### Official description

Summary

Before version 0.9.0, the HTTP/1 upstream path in pingora-proxy passed the downstream request through upstream_request_filter and wrote it to the upstream without removing the client's Connection header, other hop-by-hop headers, or the headers Connection nominated, although RFC 9110 Section 7.6.1 requires intermediaries to remove them. The HTTP/2 upstream path already removed Connection and related HTTP/1-specific headers. A client could therefore nominate a header that the application adds in upstream_request_filter (for example, Connection: keep-alive, X-Forwarded-For). A downstream HTTP/1 intermediary that honors Connection would then strip the Pingora-added header before it reached the origin.

Impact

Specifically affects chained deployments where an HTTP/1 intermediary between Pingora and the origin processes Connection nominations (for example, Go's net/http/httputil.ReverseProxy) and the origin trusts headers added by that intermediary (for example, X-Forwarded-For for IP-based authorization). A remote, unauthenticated attacker can have those headers removed, potentially bypassing authorization. The reporter demonstrated access to an IP-restricted endpoint using X-Forwarded-For for IP validation on the origin. This is the same class of issue as CVE-2022-31813 in Apache HTTP Server.

Note that Cloudflare CDN customers were unaffected, as no such chained deployment as described above exists with internal Pingora services, and Connection headers are sanitized before arriving at Pingora gateways.

Mitigation:

  *  

Upgrade to pingora 0.9.0 or later. By default, Pingora now removes hop-by-hop and Connection-nominated headers from upstream requests, and rejects requests whose Connection header nominates Host, X-Forwarded-For, X-Forwarded-Host, X-Forwarded-Proto, or a pseudo-header. This is controlled by PeerOptions::http_upstream_request_policy (HttpUpstreamRequestPolicy). Fix commits:  https://github.com/cloudflare/pingora/commit/28c18e6b6b04dd0bd937234e5950049e6d74cded ,  https://github.com/cloudflare/pingora/commit/ca23f1668eca8e78be7ba62ef0edbd458b40eeee 

  *  

Do not use HttpUpstreamRequestPolicy::preserve() if the origin relies on headers added by Pingora; it restores the old passthrough behavior.

  *  

If you cannot upgrade: in upstream_request_filter, remove the Connection header and every header it nominates before adding trusted headers.

Weakness: CWE-444 (Inconsistent Interpretation of HTTP Requests)

## Which versions are affected by CVE-2026-105299?

1 open source package ship an affected version, including pingora-proxy.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `pingora-proxy` | crates.io | From 0.0.0-0 | 0.9.0 |

## How do I fix CVE-2026-105299?

Upgrade pingora-proxy to 0.9.0 or later.

## Is CVE-2026-105299 being exploited?

There is no known exploitation of CVE-2026-105299 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-105299 and fix it if it is affected.

What it is: CVE-2026-105299 is a high-severity vulnerability in https://github.com/cloudflare/pingora, published on 20 Oct 2026. 
Exploitation: There is no known exploitation of CVE-2026-105299 in the wild and no public exploit code.

Affected packages and fixed versions:
- pingora-proxy (crates.io): affected from 0.0.0-0; fixed in 0.9.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-105299/ (Markdown: https://insights.sbomify.com/CVE-2026-105299/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-105299
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-105299
- OSV: https://osv.dev/vulnerability/CVE-2026-105299

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-105299/
Summaries are generated and may contain mistakes; the official description above is the record.
