# CVE-2026-105429: NetBird client SSH config Match line injection via peer FQDN or hostname allows local command execution

> A malicious peer can inject SSH config directives via hostname to execute arbitrary commands on NetBird client hosts.

- **Severity:** High 8.9 (`CVSS:4.0/AV:N/AC:L/AT:P/PR:H/UI:N/VC:H/VI:H/VA:H/SC:H/SI:H/SA:H`)
- **Exploited in the wild:** Not known
- **Login needed:** An administrator
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** No
- **Published:** 14 Oct 2026
- **Updated:** 16 Oct 2026
- **Also known as:** GHSA-2rq5-4vw4-m3vg, GHSA-xmg2-v32j-x2hf

## What is CVE-2026-105429?

CVE-2026-105429 is a high-severity command injection vulnerability in NetBird, published on 14 Oct 2026. An attacker needs administrator access to exploit it, with no action from the victim.

### Official description

Improper neutralization of special elements in the NetBird client SSH configuration manager (client/ssh/config/manager.go) in NetBird versions 0.60.0 through 0.74.6 allows a malicious or compromised peer to execute arbitrary commands on other NetBird client hosts. The client writes a system-wide OpenSSH drop-in file (/etc/ssh/ssh_config.d/99-netbird.conf, or the equivalent under %PROGRAMDATA%\ssh\ssh_config.d on Windows) that embeds each peer FQDN or hostname inside a double-quoted Match host directive without escaping. A peer name containing a double quote breaks out of the quoted context and injects arbitrary SSH configuration directives, including exec commands, which run locally as any user on the host the next time that user runs ssh. Desktop clients on Linux, macOS, Windows and FreeBSD are affected; the Android and iOS apps are not. The issue is fixed in version 0.74.7, which accepts a peer FQDN or hostname only if it is a valid DNS name.

Weakness: CWE-78 (Improper Neutralization of Special Elements used in an OS Command), CWE-116 (Improper Encoding or Escaping of Output)

## Which versions are affected by CVE-2026-105429?


## How do I fix CVE-2026-105429?

No fix has been published for CVE-2026-105429 yet. Limit exposure of the affected software until one is available.

## Is CVE-2026-105429 being exploited?

There is no known exploitation of CVE-2026-105429 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-105429 and fix it if it is affected.

What it is: CVE-2026-105429 is a high-severity command injection vulnerability in NetBird, published on 14 Oct 2026. An attacker needs administrator access to exploit it, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-105429 in the wild and no public exploit code.

Affected product: NetBird. No package-level version data is available, so check the vendor advisory linked from the reference page.

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-105429/ (Markdown: https://insights.sbomify.com/CVE-2026-105429/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-105429
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-105429
- OSV: https://osv.dev/vulnerability/CVE-2026-105429

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-105429/
Summaries are generated and may contain mistakes; the official description above is the record.
