# CVE-2026-105617: PostgreSQL Anonymizer: Cached plans bypass transparent dynamic masking after a role change or a new masking rule


- **Severity:** Medium 5.7 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:N/A:N`)
- **Exploited in the wild:** Not known
- **Fix available:** No
- **Published:** 28 Oct 2026
- **Updated:** 28 Oct 2026
- **Also known as:** GHSA-pmmg-m528-xf29

## What is CVE-2026-105617?

CVE-2026-105617 is a medium-severity vulnerability in DALIBO PostgreSQL Anonymizer, published on 28 Oct 2026. 

### Official description

PostgreSQL Anonymizer doesn't invalidate plans prepared after a rule was added or a role changed. Users using such plans can still see the unmasked data until the end of the session. The problem is resolved in PostgreSQL Anonymizer 3.3.0 and later versions.

Weakness: CWE-200 (Exposure of Sensitive Information to an Unauthorized Actor)

## Which versions are affected by CVE-2026-105617?


## How do I fix CVE-2026-105617?

No fix has been published for CVE-2026-105617 yet. Limit exposure of the affected software until one is available.

## Is CVE-2026-105617 being exploited?

There is no known exploitation of CVE-2026-105617 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-105617 and fix it if it is affected.

What it is: CVE-2026-105617 is a medium-severity vulnerability in DALIBO PostgreSQL Anonymizer, published on 28 Oct 2026. 
Exploitation: There is no known exploitation of CVE-2026-105617 in the wild and no public exploit code.

Affected product: DALIBO PostgreSQL Anonymizer. No package-level version data is available, so check the vendor advisory linked from the reference page.

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-105617/ (Markdown: https://insights.sbomify.com/CVE-2026-105617/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-105617
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-105617
- OSV: https://osv.dev/vulnerability/CVE-2026-105617

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-105617/
Summaries are generated and may contain mistakes; the official description above is the record.
