# CVE-2026-105638: Plane: Magic-code verifier endpoint has no rate limit, enabling 6-digit OTP brute force

> Attackers can brute-force six-digit OTPs to bypass authentication and take over accounts due to missing rate limits on the magic-code verifier endpoint.

- **Severity:** Critical 9.1 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** No
- **Published:** 5 Oct 2026
- **Updated:** 5 Oct 2026
- **Also known as:** GHSA-mqjv-rwgv-4gxq

## What is CVE-2026-105638?

CVE-2026-105638 is a critical authentication bypass vulnerability in makeplane plane, published on 5 Oct 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Plane is an open-source project management tool. Prior to 1.4.0, Plane's magic-code email login uses a six-digit numeric OTP with approximately 20 bits of entropy. The verifier has no per-code failed-attempt counter, and an incorrect code does not increment a counter, invalidate the Redis entry, or lock the email address. The verifier extends django.views.View rather than DRF's APIView, so the configured AnonRateThrottle limit does not apply. The middleware stack also contains no Django-level rate limiter such as django-ratelimit, django-axes, or an IP-throttling middleware. This vulnerability is fixed in 1.4.0.

Weakness: CWE-307 (Improper Restriction of Excessive Authentication Attempts)

## Which versions are affected by CVE-2026-105638?


## How do I fix CVE-2026-105638?

No fix has been published for CVE-2026-105638 yet. Limit exposure of the affected software until one is available.

## Is CVE-2026-105638 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-105638 exists.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-105638 and fix it if it is affected.

What it is: CVE-2026-105638 is a critical authentication bypass vulnerability in makeplane plane, published on 5 Oct 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-105638 exists.

Affected product: makeplane plane. No package-level version data is available, so check the vendor advisory linked from the reference page.

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-105638/ (Markdown: https://insights.sbomify.com/CVE-2026-105638/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-105638
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-105638
- OSV: https://osv.dev/vulnerability/CVE-2026-105638

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-105638/
Summaries are generated and may contain mistakes; the official description above is the record.
