# CVE-2026-105642: Ghost: Remote Code Execution via Bookmark Card Images

> Staff users can trigger arbitrary command execution on the server by creating bookmark cards with malicious SVG images.

- **Severity:** High 8.8 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 5 Oct 2026
- **Updated:** 5 Oct 2026
- **Also known as:** BIT-ghost-2026-105642, GHSA-788w-68h3-cvxp, MINI-4mwv-4pm7-6jg2

## What is CVE-2026-105642?

CVE-2026-105642 is a high-severity code injection vulnerability in TryGhost Ghost, published on 5 Oct 2026. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

### Official description

Ghost is a Node.js content management system. From 6.56.0 until 6.67.0, an image processing library bundled with Ghost contained a vulnerability in its SVG handling. Any staff user, including Contributors, could create a bookmark card for an attacker-controlled website, resulting in arbitrary commands being run on the Ghost server. This issue is fixed in version 6.67.0.

Weakness: CWE-94 (Improper Control of Generation of Code), CWE-1395 (Dependency on Vulnerable Third-Party Component)

## Which versions are affected by CVE-2026-105642?

3 open source packages ship an affected version, including ghost.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `ghost` | Bitnami | From 6.56.0 | 6.67.0 |
| `ghost` | npm | From 6.56.0 | 6.67.0 |
| `ghost` | npm | From 6.56.0 | 6.67.0 |

## How do I fix CVE-2026-105642?

Upgrade ghost to 6.67.0 or later.

## Is CVE-2026-105642 being exploited?

There is no known exploitation of CVE-2026-105642 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-105642 and fix it if it is affected.

What it is: CVE-2026-105642 is a high-severity code injection vulnerability in TryGhost Ghost, published on 5 Oct 2026. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2026-105642 in the wild and no public exploit code.

Affected packages and fixed versions:
- ghost (Bitnami): affected from 6.56.0; fixed in 6.67.0
- ghost (npm): affected from 6.56.0; fixed in 6.67.0
- ghost (npm): affected from 6.56.0; fixed in 6.67.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-105642/ (Markdown: https://insights.sbomify.com/CVE-2026-105642/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-105642
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-105642
- OSV: https://osv.dev/vulnerability/CVE-2026-105642

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-105642/
Summaries are generated and may contain mistakes; the official description above is the record.
