{"answers":{"affected":"3 open source packages ship an affected version, including ghost.","exploited":"There is no known exploitation of CVE-2026-105643 in the wild and no public exploit code.","fix":"Upgrade ghost to 6.67.0 or later.","what":"CVE-2026-105643 is a high-severity cross-site scripting vulnerability in TryGhost Ghost, published on 5 Oct 2026. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link."},"fix_prompt":"Check this codebase for CVE-2026-105643 and fix it if it is affected.\n\nWhat it is: CVE-2026-105643 is a high-severity cross-site scripting vulnerability in TryGhost Ghost, published on 5 Oct 2026. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.\nExploitation: There is no known exploitation of CVE-2026-105643 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- ghost (Bitnami): affected from 6.34.0; fixed in 6.67.0\n- ghost (npm): affected from 6.34.0; fixed in 6.67.0\n- ghost (npm): affected from 6.34.0; fixed in 6.67.0\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2026-105643/ (Markdown: https://insights.sbomify.com/CVE-2026-105643/index.md)","id":"CVE-2026-105643","markdown":"https://insights.sbomify.com/CVE-2026-105643/index.md","name":"CVE-2026-105643","record":{"aliases":["BIT-ghost-2026-105643","GHSA-69qc-f5m6-889c","MINI-xwxf-9hp6-vw63"],"analysis":{"component_type":"web_application","fix_type":"upgrade","impacts":["account_takeover","code_execution"],"network_reachable":"yes","non_default_config":false,"product_category":"Ghost CMS","requires_auth":"low_privilege","summary":"Stored XSS in Ghost CMS allows staff users to inject scripts via embed cards, potentially compromising other users' admin sessions.","user_interaction":"required","vuln_class":"xss"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"GitHub_M","cpe":[],"cvss":{"score":7.3,"severity":"high","source":"cna","vector":"CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:U/C:H/I:H/A:N","version":"3.1"},"cwes":[{"id":"CWE-79","name":"Improper Neutralization of Input During Web Page Generation"},{"id":"CWE-653","name":"Improper Isolation or Compartmentalization"}],"description":"Ghost is a Node.js content management system. From version 6.34.0 until 6.67.0, embed cards in the Ghost editor could bypass protections against stored cross-site scripting. Any staff user, including Contributors, could store scripts in post content that ran when another staff user opened the post in the editor, potentially compromising that user’s admin session. Self-hosted sites should leave the new  security.embedPreviewUrl  configuration option at its default value. This issue is fixed in version 6.67.0.","ecosystems":["Bitnami","npm"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Ghost: Stored XSS via Embed Card Previews","id":"CVE-2026-105643","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Bitnami","product":null,"products":[],"type":"xss","year":"2026"},"n_packages":3,"n_references":1,"next":{"headline":"Ghost: Stored XSS via SVG Files in Content Imports","id":"CVE-2026-105644"},"packages":[{"ecosystem":"Bitnami","fixed":["6.67.0"],"introduced":["6.34.0"],"last_affected":[],"package":"ghost","purl":"pkg:bitnami/ghost","source":"BIT-ghost-2026-105643"},{"ecosystem":"npm","fixed":["6.67.0"],"introduced":["6.34.0"],"last_affected":[],"package":"ghost","purl":null,"source":"GHSA-69qc-f5m6-889c"},{"ecosystem":"npm","fixed":["6.67.0"],"introduced":["6.34.0"],"last_affected":[],"package":"ghost","purl":"pkg:npm/ghost","source":"GHSA-69qc-f5m6-889c"}],"prev":{"headline":"Ghost: Remote Code Execution via Bookmark Card Images","id":"CVE-2026-105642"},"products":["Ghost"],"published":"2026-10-05","related":[],"sources":[{"class":"attribution","licence":"Apache-2.0","name":"Bitnami","prefix":"BIT"},{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"none","technical_impact":"total"},"state":"PUBLISHED","updated":"2026-10-06","vendors":["TryGhost"]},"summary":"Stored XSS in Ghost CMS allows staff users to inject scripts via embed cards, potentially compromising other users' admin sessions.","url":"https://insights.sbomify.com/CVE-2026-105643/"}