# CVE-2026-105643: Ghost: Stored XSS via Embed Card Previews

> Stored XSS in Ghost CMS allows staff users to inject scripts via embed cards, potentially compromising other users' admin sessions.

- **Severity:** High 7.3 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:U/C:H/I:H/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 5 Oct 2026
- **Updated:** 6 Oct 2026
- **Also known as:** BIT-ghost-2026-105643, GHSA-69qc-f5m6-889c, MINI-xwxf-9hp6-vw63

## What is CVE-2026-105643?

CVE-2026-105643 is a high-severity cross-site scripting vulnerability in TryGhost Ghost, published on 5 Oct 2026. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.

### Official description

Ghost is a Node.js content management system. From version 6.34.0 until 6.67.0, embed cards in the Ghost editor could bypass protections against stored cross-site scripting. Any staff user, including Contributors, could store scripts in post content that ran when another staff user opened the post in the editor, potentially compromising that user’s admin session. Self-hosted sites should leave the new  security.embedPreviewUrl  configuration option at its default value. This issue is fixed in version 6.67.0.

Weakness: CWE-79 (Improper Neutralization of Input During Web Page Generation), CWE-653 (Improper Isolation or Compartmentalization)

## Which versions are affected by CVE-2026-105643?

3 open source packages ship an affected version, including ghost.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `ghost` | Bitnami | From 6.34.0 | 6.67.0 |
| `ghost` | npm | From 6.34.0 | 6.67.0 |
| `ghost` | npm | From 6.34.0 | 6.67.0 |

## How do I fix CVE-2026-105643?

Upgrade ghost to 6.67.0 or later.

## Is CVE-2026-105643 being exploited?

There is no known exploitation of CVE-2026-105643 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-105643 and fix it if it is affected.

What it is: CVE-2026-105643 is a high-severity cross-site scripting vulnerability in TryGhost Ghost, published on 5 Oct 2026. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2026-105643 in the wild and no public exploit code.

Affected packages and fixed versions:
- ghost (Bitnami): affected from 6.34.0; fixed in 6.67.0
- ghost (npm): affected from 6.34.0; fixed in 6.67.0
- ghost (npm): affected from 6.34.0; fixed in 6.67.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-105643/ (Markdown: https://insights.sbomify.com/CVE-2026-105643/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-105643
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-105643
- OSV: https://osv.dev/vulnerability/CVE-2026-105643

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-105643/
Summaries are generated and may contain mistakes; the official description above is the record.
