CVE-2026-105646 Ghost: Regular Expression Denial of Service in Content Import

Medium 4.9 Published Updated

An administrator can cause a denial of service in Ghost CMS via a crafted content import file, requiring an upgrade to fix.

Exploited in the wild
Not known
Login needed
An administrator
Attackable
Over the internet
Victim action needed
Not needed
Fix
Available

What is CVE-2026-105646?

CVE-2026-105646 is a medium-severity denial of service vulnerability in TryGhost Ghost, published on 5 Oct 2026. An attacker needs administrator access to exploit it, with no action from the victim.

Official description

Ghost is a Node.js content management system. From 4.0.0 until 6.67.0, a crafted content import file could cause excessive CPU usage, making the Ghost server unresponsive. Exploiting this requires Administrator access. This issue is fixed in version 6.67.0.

Weakness: CWE-1333

Which versions are affected by CVE-2026-105646?

3 open source packages ship an affected version, including ghost.

PackageAffectedFixed in
ghost BitnamiFrom 4.0.06.67.0
ghost npmFrom 4.0.06.67.0
ghost npmFrom 4.0.06.67.0

How do I fix CVE-2026-105646?

Upgrade ghost to 6.67.0 or later.

Upgrade, then put limits on request size, rate and nesting depth so one client cannot exhaust the service. More about Denial of service.

Is CVE-2026-105646 being exploited?

There is no known exploitation of CVE-2026-105646 in the wild and no public exploit code.

Sources

Also known as BIT-ghost-2026-105646, GHSA-fwh9-qg68-vxp4, MINI-4g56-wr63-fcg4.

Is CVE-2026-105646 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free