# CVE-2026-105646: Ghost: Regular Expression Denial of Service in Content Import

> An administrator can cause a denial of service in Ghost CMS via a crafted content import file, requiring an upgrade to fix.

- **Severity:** Medium 4.9 (`CVSS:3.1/AV:N/AC:L/PR:H/UI:N/S:U/C:N/I:N/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** An administrator
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 5 Oct 2026
- **Updated:** 7 Oct 2026
- **Also known as:** BIT-ghost-2026-105646, GHSA-fwh9-qg68-vxp4, MINI-4g56-wr63-fcg4

## What is CVE-2026-105646?

CVE-2026-105646 is a medium-severity denial of service vulnerability in TryGhost Ghost, published on 5 Oct 2026. An attacker needs administrator access to exploit it, with no action from the victim.

### Official description

Ghost is a Node.js content management system. From 4.0.0 until 6.67.0, a crafted content import file could cause excessive CPU usage, making the Ghost server unresponsive. Exploiting this requires Administrator access. This issue is fixed in version 6.67.0.

Weakness: CWE-1333 (Inefficient Regular Expression Complexity)

## Which versions are affected by CVE-2026-105646?

3 open source packages ship an affected version, including ghost.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `ghost` | Bitnami | From 4.0.0 | 6.67.0 |
| `ghost` | npm | From 4.0.0 | 6.67.0 |
| `ghost` | npm | From 4.0.0 | 6.67.0 |

## How do I fix CVE-2026-105646?

Upgrade ghost to 6.67.0 or later.

## Is CVE-2026-105646 being exploited?

There is no known exploitation of CVE-2026-105646 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-105646 and fix it if it is affected.

What it is: CVE-2026-105646 is a medium-severity denial of service vulnerability in TryGhost Ghost, published on 5 Oct 2026. An attacker needs administrator access to exploit it, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-105646 in the wild and no public exploit code.

Affected packages and fixed versions:
- ghost (Bitnami): affected from 4.0.0; fixed in 6.67.0
- ghost (npm): affected from 4.0.0; fixed in 6.67.0
- ghost (npm): affected from 4.0.0; fixed in 6.67.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-105646/ (Markdown: https://insights.sbomify.com/CVE-2026-105646/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-105646
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-105646
- OSV: https://osv.dev/vulnerability/CVE-2026-105646

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-105646/
Summaries are generated and may contain mistakes; the official description above is the record.
