# CVE-2026-105647: Ghost: Server-Side Request Forgery in Bookmark Fetching

> Unauthenticated attackers can exploit a validation flaw in Ghost CMS to perform limited Server-Side Request Forgery against internal network hosts.

- **Severity:** Medium 4.0 (`CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:C/C:L/I:N/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 5 Oct 2026
- **Updated:** 5 Oct 2026
- **Also known as:** BIT-ghost-2026-105647, GHSA-322m-ff4g-9vx9, MINI-r5ww-xxp7-76gp

## What is CVE-2026-105647?

CVE-2026-105647 is a medium-severity server-side request forgery vulnerability in TryGhost Ghost, published on 5 Oct 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Ghost is a Node.js content management system. From 6.54.1 until 6.65.0, a validation issue allowed some functionality, such as Webmentions, to be abused by an unauthenticated user to make limited HTTP requests to hosts in the Ghost server's internal network. A successful attack would not result in any response data being returned. This issue is fixed in version 6.65.0.

Weakness: CWE-918 (Server-Side Request Forgery), CWE-367 (Time-of-check Time-of-use (TOCTOU) Race Condition)

## Which versions are affected by CVE-2026-105647?

3 open source packages ship an affected version, including ghost.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `ghost` | Bitnami | From 6.54.1 | 6.65.0 |
| `ghost` | npm | From 6.54.1 | 6.65.0 |
| `ghost` | npm | From 6.54.1 | 6.65.0 |

## How do I fix CVE-2026-105647?

Upgrade ghost to 6.65.0 or later.

## Is CVE-2026-105647 being exploited?

There is no known exploitation of CVE-2026-105647 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-105647 and fix it if it is affected.

What it is: CVE-2026-105647 is a medium-severity server-side request forgery vulnerability in TryGhost Ghost, published on 5 Oct 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-105647 in the wild and no public exploit code.

Affected packages and fixed versions:
- ghost (Bitnami): affected from 6.54.1; fixed in 6.65.0
- ghost (npm): affected from 6.54.1; fixed in 6.65.0
- ghost (npm): affected from 6.54.1; fixed in 6.65.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-105647/ (Markdown: https://insights.sbomify.com/CVE-2026-105647/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-105647
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-105647
- OSV: https://osv.dev/vulnerability/CVE-2026-105647

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-105647/
Summaries are generated and may contain mistakes; the official description above is the record.
