# CVE-2026-105680: Ghost: Authorization Issue Allowed Author Role to Delete any Post

> Authors in Ghost CMS can delete posts and pages they did not create due to missing authorization checks.

- **Severity:** Medium 6.5 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:N/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 5 Oct 2026
- **Updated:** 6 Oct 2026
- **Also known as:** BIT-ghost-2026-105680, GHSA-x3mg-q38v-m562, MINI-3c6j-47gh-r28j

## What is CVE-2026-105680?

CVE-2026-105680 is a medium-severity missing authorization vulnerability in TryGhost Ghost, published on 5 Oct 2026. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

Ghost is a Node.js content management system. From 5.81.0 until 6.60.0, staff with the Author role could delete posts and pages that they did not author. This issue is fixed in version 6.60.0.

Weakness: CWE-862 (Missing Authorization)

## Which versions are affected by CVE-2026-105680?

3 open source packages ship an affected version, including ghost.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `ghost` | Bitnami | From 5.81.0 | 6.60.0 |
| `ghost` | npm | From 5.81.0 | 6.60.0 |
| `ghost` | npm | From 5.81.0 | 6.60.0 |

## How do I fix CVE-2026-105680?

Upgrade ghost to 6.60.0 or later.

## Is CVE-2026-105680 being exploited?

There is no known exploitation of CVE-2026-105680 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-105680 and fix it if it is affected.

What it is: CVE-2026-105680 is a medium-severity missing authorization vulnerability in TryGhost Ghost, published on 5 Oct 2026. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-105680 in the wild and no public exploit code.

Affected packages and fixed versions:
- ghost (Bitnami): affected from 5.81.0; fixed in 6.60.0
- ghost (npm): affected from 5.81.0; fixed in 6.60.0
- ghost (npm): affected from 5.81.0; fixed in 6.60.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-105680/ (Markdown: https://insights.sbomify.com/CVE-2026-105680/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-105680
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-105680
- OSV: https://osv.dev/vulnerability/CVE-2026-105680

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-105680/
Summaries are generated and may contain mistakes; the official description above is the record.
