# CVE-2026-105684: Missing authorization in penpot

> Attackers with page-scoped share links can access comments and page IDs from unshared pages, exposing sensitive user data and design content.

- **Severity:** Medium 4.3 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:L/I:N/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** No
- **Published:** 5 Oct 2026
- **Updated:** 5 Oct 2026
- **Also known as:** GHSA-fwm4-hm9f-rmcp

## What is CVE-2026-105684?

CVE-2026-105684 is a medium-severity missing authorization vulnerability in penpot, published on 5 Oct 2026. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

Penpot is an open-source design and prototyping platform. Prior to 2.18.0, the get-comment-threads, get-comment-thread, and get-comments RPC commands use check-comment-permissions! but do not apply the share link's pages restriction. A holder of a page-scoped share link can retrieve comment threads and full comment bodies from other pages in the same file, including commenter names, email addresses, photos, and page identifiers. The disclosed page identifiers can also be used with affected page-reading functionality to access unshared design content. This issue is fixed in version 2.18.0.

Weakness: CWE-863 (Incorrect Authorization), CWE-200 (Exposure of Sensitive Information to an Unauthorized Actor)

## Which versions are affected by CVE-2026-105684?


## How do I fix CVE-2026-105684?

No fix has been published for CVE-2026-105684 yet. Limit exposure of the affected software until one is available.

## Is CVE-2026-105684 being exploited?

There is no known exploitation of CVE-2026-105684 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-105684 and fix it if it is affected.

What it is: CVE-2026-105684 is a medium-severity missing authorization vulnerability in penpot, published on 5 Oct 2026. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-105684 in the wild and no public exploit code.

Affected product: penpot. No package-level version data is available, so check the vendor advisory linked from the reference page.

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-105684/ (Markdown: https://insights.sbomify.com/CVE-2026-105684/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-105684
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-105684
- OSV: https://osv.dev/vulnerability/CVE-2026-105684

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-105684/
Summaries are generated and may contain mistakes; the official description above is the record.
