# CVE-2026-105691: Penpot: Authenticated OS Command Injection in Penpot SVG Exporter via Legacy fill-color

> An attacker can execute arbitrary OS commands on the server by injecting shell metacharacters into SVG fill-color values during export.

- **Severity:** Critical 9.9 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:C/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** No
- **Published:** 5 Oct 2026
- **Updated:** 6 Oct 2026
- **Also known as:** GHSA-4f36-m4hj-cv86

## What is CVE-2026-105691?

CVE-2026-105691 is a critical command injection vulnerability in penpot, published on 5 Oct 2026. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

Penpot is an open-source design and prototyping platform. Prior to 2.18.0, the SVG exporter places an attacker-controlled text object's fill-color value into a ppmcolormask command string and executes that string through child_process.exec. A user who can edit a file can store shell metacharacters in the fill color and trigger SVG export, causing commands to execute with the exporter service's privileges. The same export can be triggered through a valid public share link to a malicious file. This vulnerability is fixed in 2.18.0.

Weakness: CWE-78 (Improper Neutralization of Special Elements used in an OS Command)

## Which versions are affected by CVE-2026-105691?


## How do I fix CVE-2026-105691?

No fix has been published for CVE-2026-105691 yet. Limit exposure of the affected software until one is available.

## Is CVE-2026-105691 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-105691 exists.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-105691 and fix it if it is affected.

What it is: CVE-2026-105691 is a critical command injection vulnerability in penpot, published on 5 Oct 2026. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-105691 exists.

Affected product: penpot. No package-level version data is available, so check the vendor advisory linked from the reference page.

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-105691/ (Markdown: https://insights.sbomify.com/CVE-2026-105691/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-105691
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-105691
- OSV: https://osv.dev/vulnerability/CVE-2026-105691

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-105691/
Summaries are generated and may contain mistakes; the official description above is the record.
