# CVE-2026-105694: Penpot: Stored XSS via Unsanitised SVG Uploads

> Authenticated users can upload malicious SVGs to execute JavaScript in victims' browsers, enabling session hijacking and data theft.

- **Severity:** Medium 5.4 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:C/C:L/I:L/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** No
- **Published:** 5 Oct 2026
- **Updated:** 8 Oct 2026

## What is CVE-2026-105694?

CVE-2026-105694 is a medium-severity cross-site scripting vulnerability in penpot, published on 5 Oct 2026. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.

### Official description

Penpot is an open-source design and prototyping platform. Prior to 2.18.0, authenticated users with file-edit permission can upload SVG media whose scripts, event-handler attributes, and foreignObject elements are stored without sanitization and served as image/svg+xml from the Penpot origin. A victim who navigates to the asset URL executes attacker-controlled JavaScript in that origin, allowing requests and data access with the victim's Penpot session authority. This issue is fixed in version 2.18.0.

Weakness: CWE-79 (Improper Neutralization of Input During Web Page Generation)

## Which versions are affected by CVE-2026-105694?


## How do I fix CVE-2026-105694?

No fix has been published for CVE-2026-105694 yet. Limit exposure of the affected software until one is available.

## Is CVE-2026-105694 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-105694 exists.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-105694 and fix it if it is affected.

What it is: CVE-2026-105694 is a medium-severity cross-site scripting vulnerability in penpot, published on 5 Oct 2026. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-105694 exists.

Affected product: penpot. No package-level version data is available, so check the vendor advisory linked from the reference page.

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-105694/ (Markdown: https://insights.sbomify.com/CVE-2026-105694/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-105694
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-105694
- OSV: https://osv.dev/vulnerability/CVE-2026-105694

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-105694/
Summaries are generated and may contain mistakes; the official description above is the record.
