CVE-2026-105697 Langflow: OS command injection (RCE) via arbitrary command in MCP stdio server configuration
Attackers can execute arbitrary OS commands on the host by injecting malicious commands into MCP server configurations, leading to remote code execution.
- Exploited in the wild
- Not known
- Login needed
- Any signed-in user
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2026-105697?
CVE-2026-105697 is a critical command injection vulnerability in langflow-ai langflow, published on 5 Oct 2026. Any signed-in user can exploit it over the network, with no action from the victim.
Official description
Langflow is a tool for building and deploying AI-powered agents and workflows. Before Langflow 1.10.3, the MCP stdio transport launched whatever command / args a user put in an MCP server configuration, with no allowlist and (before 1.10.3) wrapped in bash -c "exec {command} ...". Any user able to reach the MCP server settings ("Settings → MCP Servers → Add MCP Server", POST/PATCH /api/v2/mcp/servers/{server_name}) or to build a flow with the MCP Tools component could add a "server" whose command is an arbitrary OS command (touch, rm -rf, a reverse shell, ...). The command runs on the Langflow host as the Langflow process user as soon as Langflow tries to connect to the server (listing servers, loading tools, running the flow) — even when the UI then reports that the stdio server failed to start. With the default LANGFLOW_AUTO_LOGIN=true, GET /api/v1/auto_login hands out a token without credentials, so on an exposed instance running the default configuration this is reachable without an account. AUTO_LOGIN is documented as a development-only setting; with it disabled, any authenticated (non-admin) user can exploit it. This issue is fixed in Langflow 1.10.3, langflow-base 0.10.3, and lfx 1.10.3.
Weakness: CWE-78
Which versions are affected by CVE-2026-105697?
9 open source packages ship an affected version, including langflow, langflow-base and lfx.
| Package | Affected | Fixed in |
|---|---|---|
langflow PyPI | From 1.1.2 | 1.10.3 |
langflow PyPI | From 1.1.2 | 1.10.3 |
langflow PyPI | From 1.1.2 | 1.10.3 |
langflow-base PyPI | From 0.1.2 | 0.10.3 |
langflow-base PyPI | From 0.1.2 | 0.10.3 |
langflow-base PyPI | From 0.1.2 | 0.10.3 |
3 more packages
lfx PyPI | All versions | 1.10.3 |
lfx PyPI | All versions | 1.10.3 |
lfx PyPI | All versions | 1.10.3 |
How do I fix CVE-2026-105697?
Upgrade langflow to 1.10.3 or later.
Upgrade, and pass arguments to programs as a list instead of through a shell. More about Command injection.
Is CVE-2026-105697 being exploited?
There is no known exploitation of CVE-2026-105697 in the wild and no public exploit code.
Sources
Also known as GHSA-w794-rj3p-xv45, PYSEC-2026-4237, PYSEC-2026-4239, PYSEC-2026-4241.