# CVE-2026-105697: Langflow: OS command injection (RCE) via arbitrary command in MCP stdio server configuration

> Attackers can execute arbitrary OS commands on the host by injecting malicious commands into MCP server configurations, leading to remote code execution.

- **Severity:** Critical 9.9 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:C/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 5 Oct 2026
- **Updated:** 9 Oct 2026
- **Also known as:** GHSA-w794-rj3p-xv45, PYSEC-2026-4237, PYSEC-2026-4239, PYSEC-2026-4241

## What is CVE-2026-105697?

CVE-2026-105697 is a critical command injection vulnerability in langflow-ai langflow, published on 5 Oct 2026. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

Langflow is a tool for building and deploying AI-powered agents and workflows. Before Langflow 1.10.3, the MCP stdio transport launched whatever command / args a user put in an MCP server configuration, with no allowlist and (before 1.10.3) wrapped in bash -c "exec {command} ...". Any user able to reach the MCP server settings ("Settings → MCP Servers → Add MCP Server", POST/PATCH /api/v2/mcp/servers/{server_name}) or to build a flow with the MCP Tools component could add a "server" whose command is an arbitrary OS command (touch, rm -rf, a reverse shell, ...). The command runs on the Langflow host as the Langflow process user as soon as Langflow tries to connect to the server (listing servers, loading tools, running the flow) — even when the UI then reports that the stdio server failed to start. With the default LANGFLOW_AUTO_LOGIN=true, GET /api/v1/auto_login hands out a token without credentials, so on an exposed instance running the default configuration this is reachable without an account. AUTO_LOGIN is documented as a development-only setting; with it disabled, any authenticated (non-admin) user can exploit it. This issue is fixed in Langflow 1.10.3, langflow-base 0.10.3, and lfx 1.10.3.

Weakness: CWE-78 (Improper Neutralization of Special Elements used in an OS Command)

## Which versions are affected by CVE-2026-105697?

9 open source packages ship an affected version, including langflow, langflow-base and lfx.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `langflow` | PyPI | From 1.1.2 | 1.10.3 |
| `langflow` | PyPI | From 1.1.2 | 1.10.3 |
| `langflow` | PyPI | From 1.1.2 | 1.10.3 |
| `langflow-base` | PyPI | From 0.1.2 | 0.10.3 |
| `langflow-base` | PyPI | From 0.1.2 | 0.10.3 |
| `langflow-base` | PyPI | From 0.1.2 | 0.10.3 |
| `lfx` | PyPI | All versions | 1.10.3 |
| `lfx` | PyPI | All versions | 1.10.3 |
| `lfx` | PyPI | All versions | 1.10.3 |

## How do I fix CVE-2026-105697?

Upgrade langflow to 1.10.3 or later.

## Is CVE-2026-105697 being exploited?

There is no known exploitation of CVE-2026-105697 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-105697 and fix it if it is affected.

What it is: CVE-2026-105697 is a critical command injection vulnerability in langflow-ai langflow, published on 5 Oct 2026. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-105697 in the wild and no public exploit code.

Affected packages and fixed versions:
- langflow (PyPI): affected from 1.1.2; fixed in 1.10.3
- langflow (PyPI): affected from 1.1.2; fixed in 1.10.3
- langflow (PyPI): affected from 1.1.2; fixed in 1.10.3
- langflow-base (PyPI): affected from 0.1.2; fixed in 0.10.3
- langflow-base (PyPI): affected from 0.1.2; fixed in 0.10.3
- langflow-base (PyPI): affected from 0.1.2; fixed in 0.10.3
- lfx (PyPI): affected all versions; fixed in 1.10.3
- lfx (PyPI): affected all versions; fixed in 1.10.3
- lfx (PyPI): affected all versions; fixed in 1.10.3

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-105697/ (Markdown: https://insights.sbomify.com/CVE-2026-105697/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-105697
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-105697
- OSV: https://osv.dev/vulnerability/CVE-2026-105697

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-105697/
Summaries are generated and may contain mistakes; the official description above is the record.
