# CVE-2026-105699: Langflow: Authenticated Cross-Project File Disclosure via Unscoped MCP Resource Handlers

> Authenticated users can access other users' private files and flow artifacts by manipulating resource URIs in MCP connections.

- **Severity:** High 7.1 (`CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:N/VC:H/VI:N/VA:N/SC:N/SI:N/SA:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 5 Oct 2026
- **Updated:** 8 Oct 2026
- **Also known as:** GHSA-4hmc-cfm3-w43c, PYSEC-2026-4230

## What is CVE-2026-105699?

CVE-2026-105699 is a high-severity missing authorization vulnerability in langflow-ai langflow, published on 5 Oct 2026. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

Langflow is a tool for building and deploying AI-powered agents and workflows. From 1.6.8 until 1.9.1, Langflow authenticated access to the project identifier in a project-scoped MCP connection but did not authorize the resource URI supplied to resources/read. read_resource forwarded the attacker-controlled URI to handle_read_resource, which parsed a flow_id and filename and called storage_service.get_file without verifying that the flow belonged to the authenticated user or current project. A user with access to any project-scoped MCP endpoint could therefore request another user's flow-backed file, while global handle_list_resources and handle_list_tools behavior could disclose flow and file identifiers that made targeting easier. The vulnerability disclosed uploaded documents, structured data, prompts, and other private flow artifacts across tenants but did not modify victim files or stored flows. This issue is fixed in version 1.9.1.

Weakness: CWE-639 (Authorization Bypass Through User-Controlled Key)

## Which versions are affected by CVE-2026-105699?

3 open source packages ship an affected version, including langflow.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `langflow` | PyPI | From 1.6.8 | 1.9.1 |
| `langflow` | PyPI | From 1.6.8 | 1.9.1 |
| `langflow` | PyPI | From 1.6.8 | 1.9.1 |

## How do I fix CVE-2026-105699?

Upgrade langflow to 1.9.1 or later.

## Is CVE-2026-105699 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-105699 exists.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-105699 and fix it if it is affected.

What it is: CVE-2026-105699 is a high-severity missing authorization vulnerability in langflow-ai langflow, published on 5 Oct 2026. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-105699 exists.

Affected packages and fixed versions:
- langflow (PyPI): affected from 1.6.8; fixed in 1.9.1
- langflow (PyPI): affected from 1.6.8; fixed in 1.9.1
- langflow (PyPI): affected from 1.6.8; fixed in 1.9.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-105699/ (Markdown: https://insights.sbomify.com/CVE-2026-105699/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-105699
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-105699
- OSV: https://osv.dev/vulnerability/CVE-2026-105699

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-105699/
Summaries are generated and may contain mistakes; the official description above is the record.
