# CVE-2026-105740: Langflow: Authenticated RCE via MCP Stdio transport allows any user to execute arbitrary OS commands on the server

> Authenticated users can execute arbitrary OS commands on the server by injecting malicious commands into the MCP Stdio transport configuration.

- **Severity:** Critical 9.9 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:C/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** No
- **Published:** 5 Oct 2026
- **Updated:** 6 Oct 2026

## What is CVE-2026-105740?

CVE-2026-105740 is a critical command injection vulnerability in langflow-ai langflow, published on 5 Oct 2026. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

Langflow is a tool for building and deploying AI-powered agents and workflows. Prior to 1.9.0, any authenticated Langflow user can achieve Remote Code Execution (RCE) on the server by adding an MCP server with the "Stdio" transport. The user-supplied command field is passed directly to bash -c "exec {command}" with zero validation, no allowlisting, and no sandboxing. The command executes immediately when the server list is fetched. Additionally, the env field allows arbitrary environment variable injection (e.g., LD_PRELOAD, PATH override). This vulnerability is fixed in 1.9.0.

Weakness: CWE-78 (Improper Neutralization of Special Elements used in an OS Command)

## Which versions are affected by CVE-2026-105740?


## How do I fix CVE-2026-105740?

No fix has been published for CVE-2026-105740 yet. Limit exposure of the affected software until one is available.

## Is CVE-2026-105740 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-105740 exists.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-105740 and fix it if it is affected.

What it is: CVE-2026-105740 is a critical command injection vulnerability in langflow-ai langflow, published on 5 Oct 2026. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-105740 exists.

Affected product: langflow-ai langflow. No package-level version data is available, so check the vendor advisory linked from the reference page.

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-105740/ (Markdown: https://insights.sbomify.com/CVE-2026-105740/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-105740
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-105740
- OSV: https://osv.dev/vulnerability/CVE-2026-105740

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-105740/
Summaries are generated and may contain mistakes; the official description above is the record.
