{"answers":{"affected":"3 open source packages ship an affected version, including langflow.","exploited":"It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-105741 exists.","fix":"Upgrade langflow to 1.10.3 or later.","what":"CVE-2026-105741 is a high-severity vulnerability in langflow-ai langflow, published on 5 Oct 2026. Any signed-in user can exploit it over the network, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2026-105741 and fix it if it is affected.\n\nWhat it is: CVE-2026-105741 is a high-severity vulnerability in langflow-ai langflow, published on 5 Oct 2026. Any signed-in user can exploit it over the network, with no action from the victim.\nExploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-105741 exists.\n\nAffected packages and fixed versions:\n- langflow (PyPI): affected from 1.5.0; fixed in 1.10.3\n- langflow (PyPI): affected from 1.5.0; fixed in 1.10.3\n- langflow (PyPI): affected from 1.5.0; fixed in 1.10.3\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2026-105741/ (Markdown: https://insights.sbomify.com/CVE-2026-105741/index.md)","id":"CVE-2026-105741","markdown":"https://insights.sbomify.com/CVE-2026-105741/index.md","name":"CVE-2026-105741","record":{"aliases":["GHSA-4f6c-2vvp-gw82","PYSEC-2026-4229"],"analysis":{"component_type":"web_application","fix_type":"upgrade","impacts":["data_modify","security_bypass"],"network_reachable":"yes","non_default_config":false,"product_category":"AI workflow builder","requires_auth":"low_privilege","summary":"Authenticated attackers can bypass local-only restrictions via IP spoofing to overwrite MCP configuration files on the server.","user_interaction":"not_required","vuln_class":"security_feature_bypass"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"GitHub_M","cpe":[],"cvss":{"score":7.1,"severity":"high","source":"cna","vector":"CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:H/A:L","version":"3.1"},"cwes":[{"id":"CWE-345","name":"Insufficient Verification of Data Authenticity"},{"id":"CWE-290","name":"Authentication Bypass by Spoofing"}],"description":"Langflow is a tool for building and deploying AI-powered agents and workflows. From 1.5.0 until 1.10.3, an IP spoofing vulnerability in the Model Context Protocol (MCP) configuration installation endpoint (POST /api/v1/mcp/project/{project_id}/install) allowed authenticated remote attackers to bypass the \"local-only\" access restriction. By sending a spoofed X-Forwarded-For: 127.0.0.1 header, an attacker could make the server treat the request as originating from localhost, letting them write/overwrite an MCP client configuration file on the server's filesystem. This vulnerability is fixed in 1.10.3.","ecosystems":["PyPI"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"weaponised"},"has_fix":true,"headline":"Langflow: IP Spoofing Bypass via `X-Forwarded-For` Allowing Remote Configuration Write","id":"CVE-2026-105741","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"PyPI","product":null,"products":[],"type":"security_feature_bypass","year":"2026"},"n_packages":3,"n_references":5,"next":{"headline":"Docling: Configured HTTP headers sent to every remote image host named by a document","id":"CVE-2026-105742"},"packages":[{"ecosystem":"PyPI","fixed":["1.10.3"],"introduced":["1.5.0"],"last_affected":[],"package":"langflow","purl":null,"source":"GHSA-4f6c-2vvp-gw82"},{"ecosystem":"PyPI","fixed":["1.10.3"],"introduced":["1.5.0"],"last_affected":[],"package":"langflow","purl":"pkg:pypi/langflow","source":"GHSA-4f6c-2vvp-gw82"},{"ecosystem":"PyPI","fixed":["1.10.3"],"introduced":["1.5.0"],"last_affected":[],"package":"langflow","purl":"pkg:pypi/langflow","source":"PYSEC-2026-4229"}],"prev":{"headline":"Langflow: Authenticated RCE via MCP Stdio transport allows any user to execute arbitrary OS commands on the server","id":"CVE-2026-105740"},"products":["langflow"],"published":"2026-10-05","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"CC BY 4.0","name":"PyPA Advisory Database","prefix":"PYSEC"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"poc","technical_impact":"partial"},"state":"PUBLISHED","updated":"2026-10-06","vendors":["langflow-ai"]},"summary":"Authenticated attackers can bypass local-only restrictions via IP spoofing to overwrite MCP configuration files on the server.","url":"https://insights.sbomify.com/CVE-2026-105741/"}