# CVE-2026-105741: Langflow: IP Spoofing Bypass via `X-Forwarded-For` Allowing Remote Configuration Write

> Authenticated attackers can bypass local-only restrictions via IP spoofing to overwrite MCP configuration files on the server.

- **Severity:** High 7.1 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:H/A:L`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 5 Oct 2026
- **Updated:** 6 Oct 2026
- **Also known as:** GHSA-4f6c-2vvp-gw82, PYSEC-2026-4229

## What is CVE-2026-105741?

CVE-2026-105741 is a high-severity vulnerability in langflow-ai langflow, published on 5 Oct 2026. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

Langflow is a tool for building and deploying AI-powered agents and workflows. From 1.5.0 until 1.10.3, an IP spoofing vulnerability in the Model Context Protocol (MCP) configuration installation endpoint (POST /api/v1/mcp/project/{project_id}/install) allowed authenticated remote attackers to bypass the "local-only" access restriction. By sending a spoofed X-Forwarded-For: 127.0.0.1 header, an attacker could make the server treat the request as originating from localhost, letting them write/overwrite an MCP client configuration file on the server's filesystem. This vulnerability is fixed in 1.10.3.

Weakness: CWE-345 (Insufficient Verification of Data Authenticity), CWE-290 (Authentication Bypass by Spoofing)

## Which versions are affected by CVE-2026-105741?

3 open source packages ship an affected version, including langflow.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `langflow` | PyPI | From 1.5.0 | 1.10.3 |
| `langflow` | PyPI | From 1.5.0 | 1.10.3 |
| `langflow` | PyPI | From 1.5.0 | 1.10.3 |

## How do I fix CVE-2026-105741?

Upgrade langflow to 1.10.3 or later.

## Is CVE-2026-105741 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-105741 exists.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-105741 and fix it if it is affected.

What it is: CVE-2026-105741 is a high-severity vulnerability in langflow-ai langflow, published on 5 Oct 2026. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-105741 exists.

Affected packages and fixed versions:
- langflow (PyPI): affected from 1.5.0; fixed in 1.10.3
- langflow (PyPI): affected from 1.5.0; fixed in 1.10.3
- langflow (PyPI): affected from 1.5.0; fixed in 1.10.3

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-105741/ (Markdown: https://insights.sbomify.com/CVE-2026-105741/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-105741
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-105741
- OSV: https://osv.dev/vulnerability/CVE-2026-105741

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-105741/
Summaries are generated and may contain mistakes; the official description above is the record.
