# CVE-2026-105742: Docling: Configured HTTP headers sent to every remote image host named by a document

> Attackers can steal configured HTTP headers, such as API keys, by crafting documents with remote image URLs when remote fetching is enabled.

- **Severity:** Low 3.7 (`CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:L/I:N/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 5 Oct 2026
- **Updated:** 6 Oct 2026
- **Also known as:** GHSA-p3fw-7699-7926, PYSEC-2026-4189, PYSEC-2026-4212

## What is CVE-2026-105742?

CVE-2026-105742 is a low-severity vulnerability in docling-project docling, published on 5 Oct 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Docling simplifies document processing by parsing diverse formats and providing integrations with the generative AI ecosystem. From 2.95.0 until 2.132.0, the HTML image resource loader in docling/backend/utils/image_resource_loader.py forwards headers configured through the HTMLBackendOptions.headers setting to every remote image URL named by an untrusted document when enable_remote_fetch=True and fetch_images=True. The loader does not restrict those credentials to the source document's origin, allowing requests that carry custom headers such as API keys and cookies to follow cross-origin redirects and expose the caller's configured credentials to a document author. The default configuration is not affected because remote fetching and configured headers are required. This issue is fixed in 2.132.0.

Weakness: CWE-522 (Insufficiently Protected Credentials), CWE-201 (Insertion of Sensitive Information Into Sent Data)

## Which versions are affected by CVE-2026-105742?

6 open source packages ship an affected version, including docling and docling-slim. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `docling` | PyPI | From 2.95.0 | 2.132.0 |
| `docling` | PyPI | From 2.95.0 | 2.132.0 |
| `docling` | PyPI | From 2.95.0 | 2.132.0 |
| `docling-slim` | PyPI | From 2.95.0 | 2.132.0 |
| `docling-slim` | PyPI | From 2.95.0 | 2.132.0 |
| `docling-slim` | PyPI | From 2.95.0 | 2.132.0 |

Products: Docling Docling.

## How do I fix CVE-2026-105742?

Upgrade docling to 2.132.0 or later.

## Is CVE-2026-105742 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-105742 exists.

## Other vulnerabilities in docling-project docling

- [CVE-2026-44016](https://insights.sbomify.com/CVE-2026-44016/): Docling: Unsafe Playwright-based HTML Rendering (high 8.2)
- [CVE-2026-105744](https://insights.sbomify.com/CVE-2026-105744/): Docling has arbitrary file read/write (and command execution when shell-escape is enabled) when rendering untrusted TikZ with the opt-in Tectonic engine (high 7.5)
- [CVE-2026-44017](https://insights.sbomify.com/CVE-2026-44017/): Docling: Unsafe Zip Extraction in EasyOCR Model Download (high 7.5)
- [CVE-2026-44020](https://insights.sbomify.com/CVE-2026-44020/): Docling: Unsafe XML Entity Expansion in USPTO Patent Backend (high 7.5)
- [CVE-2026-47214](https://insights.sbomify.com/CVE-2026-47214/): Docling: Unsafe URI and Path Handling in HTML Backend (high 7.1)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-105742 and fix it if it is affected.

What it is: CVE-2026-105742 is a low-severity vulnerability in docling-project docling, published on 5 Oct 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-105742 exists.

Affected packages and fixed versions:
- docling (PyPI): affected from 2.95.0; fixed in 2.132.0
- docling (PyPI): affected from 2.95.0; fixed in 2.132.0
- docling (PyPI): affected from 2.95.0; fixed in 2.132.0
- docling-slim (PyPI): affected from 2.95.0; fixed in 2.132.0
- docling-slim (PyPI): affected from 2.95.0; fixed in 2.132.0
- docling-slim (PyPI): affected from 2.95.0; fixed in 2.132.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-105742/ (Markdown: https://insights.sbomify.com/CVE-2026-105742/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-105742
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-105742
- OSV: https://osv.dev/vulnerability/CVE-2026-105742

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-105742/
Summaries are generated and may contain mistakes; the official description above is the record.
