# CVE-2026-105744: Docling has arbitrary file read/write (and command execution when shell-escape is enabled) when rendering untrusted TikZ with the opt-in Tectonic engine

> Attackers can read or write arbitrary files and potentially execute commands via crafted TikZ input when the opt-in Tectonic engine is enabled.

- **Severity:** High 7.5 (`CVSS:3.1/AV:N/AC:H/PR:N/UI:R/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 5 Oct 2026
- **Updated:** 6 Oct 2026
- **Also known as:** GHSA-x3q2-h9hx-4r4j, PYSEC-2026-4191, PYSEC-2026-4216

## What is CVE-2026-105744?

CVE-2026-105744 is a high-severity path traversal vulnerability in docling-project docling, published on 5 Oct 2026. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

### Official description

Docling simplifies document processing by parsing diverse formats and providing integrations with the generative AI ecosystem. From 2.94.0 until 2.132.0, callers that opt into LatexBackendOptions(tikz_engine="tectonic") invoke docling/backend/latex/engines/tectonic.py to compile an untrusted TikZ body and document preamble without restricting TeX file primitives including \openin and \openout. Crafted input can read files available to the converter and create or overwrite writable files, and enabling the tikz_engine_allow_shell_escape option additionally permits shell commands through TeX. The default configuration, which does not enable Tectonic rendering, is not affected. This vulnerability is fixed in 2.132.0.

Weakness: CWE-73 (External Control of File Name or Path), CWE-22 (Improper Limitation of a Pathname to a Restricted Directory), CWE-1188 (Initialization of a Resource with an Insecure Default)

## Which versions are affected by CVE-2026-105744?

6 open source packages ship an affected version, including docling and docling-slim. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `docling` | PyPI | From 2.94.0 | 2.132.0 |
| `docling` | PyPI | From 2.94.0 | 2.132.0 |
| `docling` | PyPI | From 2.94.0 | 2.132.0 |
| `docling-slim` | PyPI | From 2.94.0 | 2.132.0 |
| `docling-slim` | PyPI | From 2.94.0 | 2.132.0 |
| `docling-slim` | PyPI | From 2.94.0 | 2.132.0 |

Products: Docling Docling.

## How do I fix CVE-2026-105744?

Upgrade docling to 2.132.0 or later.

## Is CVE-2026-105744 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-105744 exists.

## Other vulnerabilities in docling-project docling

- [CVE-2026-44016](https://insights.sbomify.com/CVE-2026-44016/): Docling: Unsafe Playwright-based HTML Rendering (high 8.2)
- [CVE-2026-44017](https://insights.sbomify.com/CVE-2026-44017/): Docling: Unsafe Zip Extraction in EasyOCR Model Download (high 7.5)
- [CVE-2026-44020](https://insights.sbomify.com/CVE-2026-44020/): Docling: Unsafe XML Entity Expansion in USPTO Patent Backend (high 7.5)
- [CVE-2026-47214](https://insights.sbomify.com/CVE-2026-47214/): Docling: Unsafe URI and Path Handling in HTML Backend (high 7.1)
- [CVE-2026-105751](https://insights.sbomify.com/CVE-2026-105751/): Docling: Arbitrary local file read via draw:image xlink:href in the OpenDocument backend (medium 6.9)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-105744 and fix it if it is affected.

What it is: CVE-2026-105744 is a high-severity path traversal vulnerability in docling-project docling, published on 5 Oct 2026. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-105744 exists.

Affected packages and fixed versions:
- docling (PyPI): affected from 2.94.0; fixed in 2.132.0
- docling (PyPI): affected from 2.94.0; fixed in 2.132.0
- docling (PyPI): affected from 2.94.0; fixed in 2.132.0
- docling-slim (PyPI): affected from 2.94.0; fixed in 2.132.0
- docling-slim (PyPI): affected from 2.94.0; fixed in 2.132.0
- docling-slim (PyPI): affected from 2.94.0; fixed in 2.132.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-105744/ (Markdown: https://insights.sbomify.com/CVE-2026-105744/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-105744
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-105744
- OSV: https://osv.dev/vulnerability/CVE-2026-105744

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-105744/
Summaries are generated and may contain mistakes; the official description above is the record.
